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biznovate
Programme Overview & Daily Agenda

5-Day Comprehensive TOS Training | Lekki Freeport Terminal

DAY 1

SPARCS N4 Basics

• Architecture & Data Flow

• Topology

• Data Model

• Navigation & Tabs

• Lists, Search & Filters

• Vessel Operations

DAY 2

Basic Administration

• Reference Data

• Events & Services

• Holds & Permissions

• Business Rules

• Unit Admin

• Security & Flex Fields

DAY 3

Mobile | Gate | XPS

• N4 Mobile RDT

• Yard Inspection

• Gate Configuration

• N4 Licensing

• XPS Administration

DAY 4

Advanced Admin

• TOS Restart

• EDI Inbound/Outbound

• BAPLIE Reading

• Reporting

• Jasper Integration

DAY 5

N4 Billing

• Billing Overview

• Tariffs & GL Codes

• Contracts

• Invoice Generation

• Payments & Credit Notes

• Sequencing

09:00 Start  |  10:45 Break  |  12:30–13:30 Lunch  |  15:15 Break  |  16:00 Close  |  Accounts: user01–user08  |  URL: [server]:9080/apex/apex.jnlp
NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited Programme



DAY

1
SPARCS N4 Basics

Architecture | Topology | Data Model | Navigation | Lists & 
Filters | Vessel Operations

biznovate

T O D A Y ' S  A G E N D A

1.  Product Overview – What is SPARCS N4?

2.  N4/XPS Architecture (Basic Architecture Diagram)

3.  SPARCS N4 Cluster Architecture

4.  How Updates Flow: N4 → Cache → XPS (6 Steps)

5.  N4 Topology: Operator → Complex → Facility → Yard

6.  Unit Visit States (ADVISED / ACTIVE / DEPARTED)

7.  UFV Transit States (Fine-Grain 1-7)

8.  Category vs Routing – A Critical Distinction

9.  Logging In to N4 – Step by Step

10.  Three Modes of Operation

11.  Operations Mode – Functions & Menu Areas

12.  Configuration Mode – Functions

13.  Administration Mode – Functions

14.  Tab Management & Keyboard Shortcuts

15.  The N4 Unit Inspector – All Tabs

16.  N4 Help System & Community Portal

17.  Using the Units List View

18.  Quick Search – Wildcard & Column Filtering

19.  Filter Panel – Multi-Criteria Search

20.  Filter Operators Reference

21.  Parameterising Filters

22.  Saving & Reusing Filters

23.  My List Feature

24.  Vessel Planning Workflow (6 Steps)

25.  Creating a Vessel Service & Port Rotation

26.  Creating a Vessel Class

27.  Creating a Vessel

28.  Vessel Record Fields Reference

29.  Creating a Vessel Visit

30.  Vessel Visit Phases

31.  Manually Entering a Stowplan

32.  Discharging Containers

33.  Creating an Export Booking

34.  Booking Fields Reference

35.  Creating a Bill of Lading

36.  Day 1 Lab Exercises
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T O D A Y ' S  A G E N D A  C O N T ’ D

18.  Quick Search – Wildcard & Column Filtering

19.  Filter Panel – Multi-Criteria Search

20.  Filter Operators Reference

21.  Parameterising Filters

22.  Saving & Reusing Filters

23.  My List Feature

24.  Vessel Planning Workflow (6 Steps)

25.  Creating a Vessel Service & Port Rotation

26.  Creating a Vessel Class

27.  Creating a Vessel

28.  Vessel Record Fields Reference

29.  Creating a Vessel Visit

30.  Vessel Visit Phases

31.  Manually Entering a Stowplan

32.  Discharging Containers

33.  Creating an Export Booking

34.  Booking Fields Reference

35.  Creating a Bill of Lading

36.  Day 1 Lab Exercises
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35.  Creating a Bill of Lading

36.  Day 1 Lab Exercises



Section 1.1

Product Overview

What is NAVIS SPARCS N4?
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biznovate
1.1 – What is NAVIS SPARCS N4?

Product identity, platform and technical overview

Full Name NAVIS SPARCS N4 (formerly SPARCS – Synchronous Planning and Real-time Control System)

Vendor Navis LLC (Cargotec) – now owned by Kaleris. Industry-leading TOS provider.

Platform Java-based Rich Internet Application (RIA) – Java Swing technology

Technology Pure Java – runs on any J2EE Application Server

Client Access Only requires JRE on client workstation – NO heavy installation needed

Network Traffic 10× LESS traffic than HTML applications – optimised for terminal networks

OS Support Windows, Apple, Linux, Unix – any client OS with Java Runtime Environment

Primary Users Yard Planners, Vessel/Rail Planners, Execution Managers, Gate Clerks, IT Administrators

Core Capability Real-time graphical viewing and planning for ALL container movements at a terminal

Key principle: N4 is the MASTER database. XPS reads from N4 via the Cache. Everything defined ONCE in N4 flows to XPS automatically.
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1.1 – N4/XPS Architecture – Basic Architecture

From the Training Manual

Basic Architecture: Internet/VPN, Web Firewall, Load Balancers, App Servers 1&2, DB Cluster, XPS Master/Backup, XPS Clients, XPS Radio Server, RDTs, Coherence CacheReliable 24×7 operations | Redundancy and Fault Tolerance | Distributed architecture keeps operations running
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biznovate
1.1 – SPARCS N4 Cluster Architecture

How N4 nodes connect to the cache and XPS

SPARCS N4 Basic Architecture: RDBMS → SparcsN4 Cluster (SN4 nodes) → Operational Data Cache → XPS, Radio Server, Customer Systems via N4 APIs, SPARCS clients
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biznovate
1.1 – SPARCS N4 Architecture (Detail View)

Cache Cluster and XPS Bridge connection

Cache Cluster with named caches (PARTICIPANTS, OBJECTS, JOURNAL, MISC) → Bridge → XPS → Live View. N4 ULC, multiple N4 nodes, L2 cache, database.
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1.1 – N4 Architecture Components Reference

All system components and their roles

N4 Application Nodes Multiple N4 service instances running on Cluster Servers

Center Node Master controller of the Cache – communicates with XPS via the Bridge

Standby Node Takes over if the Center Node goes down – minimises XPS downtime

Cache (Cloud) Shared operational data layer between N4 nodes and XPS

L2 Cache Named caches: PARTICIPANTS, OBJECTS, JOURNAL, MISC

XPS Expert Planning System – reads from Cache for real-time yard/vessel planning

N4 Mobile (RDT) Radio Data Terminal interface connecting field devices to N4

N4 Share High-availability file share – extremely important for stable operations

N4 APIs Customer systems integration layer for custom extensions and third-party systems
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biznovate
1.1 – How Updates Flow: N4 → Cache → XPS

The 6-step real-time update sequence

N4 Data Flow – From Update to XPS

Step 1: User makes an update in N4 (e.g., arrives a vessel, gates in a container)

Step 2: Update writes to the N4 Database (Oracle or PostgreSQL – the master record store)

Step 3: Database updates the L2 Cache (Coherence Cache Cluster)

Step 4: Cache is read by XPS in real time via the Bridge

Step 5: XPS updates graphical views for planners instantly

Step 6: N4 Mobile (RDT) also receives real-time updates from Cache

Key Architecture Principle

N4 is the MASTER database of all information: containers, vessel visits, reference data

XPS is NOT a separate database – it reads from N4 via the Cache

In old SPARCS/Express the systems were SEPARATE – with N4 everything is defined ONCE

All changes flow automatically: N4 → Cache → XPS → N4 Mobile (no manual sync required)

This is the most important concept to understand: ONE source of truth (N4), real-time everywhere else.
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Section 1.2

N4 Topology

Operator → Complex → Facility → Yard
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1.2 – N4 Topology Pyramid

From the Training Manual – Operator → Complex → Facility → Yard

Topology Pyramid showing N4 System → Operator → Complex → Facility → Quay/Gate/Rail/Yard hierarchyWhen logging in, always select the correct Facility scope. All operational data is FACILITY-SCOPED.
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biznovate
1.2 – Topology Diagram (Detailed View)

All levels of the N4 topology hierarchy

Detailed topology: System, Operator, Complex, Facility, Yard/Quay/Gate/Rail with their relationshipsA unit (UFV) can only reside at ONE Facility within a Complex at any time.
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1.2 – Topology Levels Reference

What each level represents and contains

N4 System The top-level software platform. All reference data starts here.

Operator An operator may have one or more Complexes. Complexes operate independently.

Complex One or more highly integrated Facilities. A unit can only reside at ONE Facility within a Complex at a time.

Facility
Unique transport hub at a specific geographic location. Has a 1:1 relationship with a Yard. ALL operational data 
associated here.

Yard Container positions (Block/Row/Tier). Cranes and yard operations work at Yard level.

Quay Vessel berth area. Cranes, discharge/load operations are at Quay berths.

Gate Truck entry/exit points. Gate transactions recorded at Gate level.

Rail Rail car operations and rail ramp entry/exit. Rail schedules are Facility-scoped.

Tip: Always confirm you are working in the correct Facility before making changes – especially in a multi-facility environment like Lekki Freeport Terminal.
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Section 1.3

N4 Data Model

Unit States, Transit States & Routing
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biznovate
1.3 – Unit (UFV) Transit States Timeline

From the Training Manual

UFV Transit State timeline: 1-Advised → 2-Inbound → 3-ECIn → 4-Yard → 5-ECOut → 6-Loaded → 7-Departed
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biznovate
1.3 – Unit Visit States (Coarse-Grain)

Three top-level states for every container visit

ADVISED Unit pre-advised (via EDI/booking) but has NOT yet arrived at the Facility. NOT visible in SPARCS XPS.

ACTIVE Unit is currently at the Facility (in yard, on vessel, at gate). VISIBLE and manageable in SPARCS XPS.

DEPARTED Unit has physically left the Facility (truck, vessel, rail). No longer in active yard inventory.

Visit States are the COARSE-GRAIN status. Within ACTIVE, the system tracks fine-grain Transit States (1-7).
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biznovate
1.3 – UFV Transit States (Fine-Grain)

7 transit states tracking precise location and movement

1. ADVISED Incoming, but not certain to arrive at the Facility

2. INBOUND Incoming and essentially certain to arrive (e.g., on an arrived vessel)

3. EC-IN Received or discharged from carrier, but NOT yet placed in a Yard Position

4. YARD Currently placed in a specific Yard Position (block/row/tier) – most common operational state

5. EC-OUT In progress toward delivery or loading (work instruction created in XPS)

6. LOADED Loaded onto the Outbound Carrier (vessel, truck, or rail)

7. DEPARTED Has departed on the Outbound Carrier – visit state moves to DEPARTED

RETIRED Special case – unit has come to end-of-life (e.g., empty stuffed into LCL cargo)
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1.3 – Category vs Routing – A Critical Distinction

These are INDEPENDENT concepts – do not confuse them

CATEGORY – Legal Designation

IMPORT: Goods arriving from abroad for local delivery

EXPORT: Goods leaving the country on a vessel

TRANSSHIP: Transit cargo – arrives and departs by vessel

DOMESTIC: Coastal/inland movement within the country

STORAGE: Long-term storage at the terminal

THROUGH: Stay-on-Board or Restow containers

Category is INDEPENDENT of routing – a container's category does NOT 
change when its routing changes

ROUTING – Carrier Journey

Declared Inbound: The carrier EXPECTED to bring the unit to the Complex

Actual Inbound: The carrier that ACTUALLY brought the unit to the Facility

Declared Outbound: The carrier that WILL remove the unit from the 
Complex

Load Port (POL): Where the unit was loaded onto the Declared Inbound 
carrier

Discharge Port (POD): Where the unit will be discharged from Outbound 
carrier

2nd Discharge Port: Where the unit goes AFTER the primary Discharge Port

Routing defines the JOURNEY. Category defines the LEGAL STATUS.

Example: A 20ft Import container with POD=NGAPP rolled to a different vessel still has Category=IMPORT – routing changed, category stayed the same.
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Section 1.4

Logging In & Modes of Operation

N4 Login, Scope Selection, Three Modes
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1.4 – Logging In to N4 – Login Screen & Scope Selector

From the Training Manual

N4 Login screen showing username/password fields, then N4 scope selector with Operator/Complex/Facility/Yard dropdownsTraining URL: http://[server]:9080/apex/apex.jnlp | Accounts: user01–user08 | Password: userXY | Facility: LFT | TEST ENVIRONMENT ONLY
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1.4 – Login Steps

Step-by-step login procedure for N4

Step-by-Step Login Procedure

Step 1: Open Google Chrome. Navigate to the N4 test environment URL provided by your trainer.

Step 2: Click the link to load the Java-based Rich Thin Client (N4 apex.jnlp). Java Web Start will launch.

Step 3: When the login screen appears, enter your Username (e.g., user01) and Password (userXY).

Step 4: After login, select your Operator, Complex and Facility scope from the dropdowns. Click OK.

Step 5: The N4 main window loads. You are now ready to begin working.

Training Environment Details

URL: http://[server]:9280/apex/apex.jnlp  (replace [server] with address provided by trainer)

Trainee Accounts: user01 through user08 (assigned by trainer on Day 1)

Default Password: userXY where XY is your user number (e.g., user01 = user01)

Facility to select: LFT (Lekki Freeport Terminal)

XPS Access: Via the XPS shortcut in the TOS Folder on your desktop

ALWAYS use the TEST environment during training. NEVER perform exercises on the production system.
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1.4 – Three Modes of Operation

N4 top navigation bar showing mode selector tabs

N4 top navigation bar clearly showing OPERATIONS / CONFIGURATION / ADMINISTRATION mode selector tabsSwitching modes changes the ENTIRE top menu bar. Access is controlled by user privileges.
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1.4 – Three Modes – Detailed Functions

What each mode is used for

OPERATIONS Mode

Units – View, search, update and manage all container units

Vessels – Vessel visits, stowplan, discharge, load, bookings, BLs

Gate – Gate transactions, EDOs, EROs, appointments

Yard – Yard inventory, record yard moves, work instructions

Rail – Rail schedule, car management, discharges/loads

Reports – Define and run operational reports

CONFIGURATION Mode

Equipment Types, Damage Codes, Prefixes, Ranges, Equivalents

Carriers – Vessel Classes, Vessels, Carrier Services, Port Rotations

Organizations – Line Operators (SCAC/BIC), Trucking Cos, Shippers

Services – Event Types, Auto-Update Rules, Holds/Permissions, Business Rules

Routing Points – UN Locations, Routing Points, Groups

ADMINISTRATION Mode

EDI Configuration – Trading Partners, Mailboxes, Sessions, Posting Rules

Security – Roles, Privileges, Users, Business Groups, Delegated Security

Settings – 400+ N4 system settings per topology level

Fields (Flex Fields) – Custom field configuration and LOVs

Topology – Operator/Complex/Facility/Yard definitions
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Section 1.5

Navigation & the Unit Inspector

Tabs, Shortcuts, Inspector, Help System
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1.5 – Tab Management – N4 Multi-Window Interface

Opening, closing and navigating N4 tab windows

N4 tab-based multi-window interface showing open tabs, tab headers and navigation options
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1.5 – Keyboard Shortcuts Reference

All key shortcuts for efficient N4 navigation

Ctrl + O Opens a quick search box to jump to ANY N4 screen instantly

Ctrl + F4 Close the current tab

Ctrl + Shift + F4 Close ALL open tabs at once

Right-click tab header → Close All Tabs But This (context menu option)

Alt + Left/Right Arrow Navigate between open tabs

Ctrl + U UnDock (float) current tab as a separate window (cannot be re-docked)

Ctrl + D Duplicate the current tab

Ctrl + Shift + F Add current tab to Favourites

Max tabs open 15 tabs maximum (can be reduced but not increased via N4 Settings)

Tabs can be UnDocked (floated) but CANNOT be ReDocked. Forms with parent/child segments require saving the parent before updating children.
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1.5 – Tab Management (Continued)

Additional tab navigation details from the manual

N4 tab management interface showing multiple tabs, navigation controls and tab management options
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1.5 – The N4 Unit Inspector

The most commonly used tool for investigation and action

Unit Inspector overview – how to open and key sections: Details Tab, All Equipment Tab, 
Container Basics, Ownership, Position Frame, Actions Menu

Unit Inspector (continued) – Global Inspector tool (magnifying glass top-right of N4) – enter 
last 4+ digits of container number

Open methods: (1) Double-click unit row | (2) Right-click → Inspect Unit | (3) Global Inspector (top-right magnifying glass)
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1.5 – Unit Inspector Tabs Reference

Complete guide to all Unit Inspector tabs and what they contain

Details Tab Status (visit state, transit state), routing, position, category, line, weight, booking reference

All Equipment Tab Physical equipment details, damage records, hazard placard information

Container Basics Tab ISO type, nominal dimensions, equipment features, equipment grade

Ownership Tab Freight kind (FCL/LCL), shipper, consignee, Bill of Lading number

Position Frame Current yard position, planned position, yard slot details (Block/Row/Tier)

Actions Menu All available update actions for the unit: Update, Transactions, Administration

Event History Full chronological audit trail of ALL events recorded against the unit visit

Holds/Perms Tab Active holds and ungranted permissions with source events and veto events
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1.5 – N4 Help System & Navis Community Portal

Support resources available to N4 administrators

N4 Built-In Help System

Access via the '?' icon on any N4 screen – help is CONTEXT-SENSITIVE to the current screen

The help panel is user-privilege controlled – content shown is relevant to the current user's screen

Help includes: Vessel Inspector Guide, Process Maps, Model Docs, Java API Docs

Help content changes as you click different hyperlinks – fully integrated with the application

Each N4 screen has its own dedicated help page – always accessible with one click

Navis Community Portal (Online Resource)

URL: community.navis.com – access requires a Navis/Kaleris account (provided by trainer)

Knowledge base articles for all N4 versions and modules

Release notes and new feature documentation for each N4 release

Submit and track support tickets for technical issues

Community forums – peer support from TOS administrators worldwide

Bookmark the Navis Community Portal – it is the #1 resource for post-training troubleshooting and self-service support.
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1.5 – N4 Help System (Screenshot)

Context-sensitive help panel in action

N4 Help system screenshot showing the help panel with content relevant to the current screen, hyperlinks and navigation
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Section 1.6

Lists, Quick Search & Filters

Finding Containers Efficiently in N4
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1.6 – Using the Units List View

Navigate to Operations → Unit → Units

Units List View – Primary Workspace

Navigate to: Operations → Unit → Units – primary workspace for finding and working with containers

SORT: Left-click any column header to sort ascending. Click again for descending.

SECONDARY SORT: Right-click a column header → Sort ASC or Sort DESC (adds second sort level)

REORDER COLUMNS: Click and drag column headers to reorder the view

ADD/REMOVE COLUMNS: Right-click any column header to add new attributes or remove existing ones

TOTAL COUNT: Number of rows in current filtered view is shown in the tab header (e.g., Units [1,247])

ROW SELECT: Click to select one | Shift+click for range | Ctrl+click for multi-select

Quick Search Field

Quick Search is at the TOP of every N4 list view – provides fast global text search

IMPORTANT: Only searches attributes that are VISIBLE as columns in the current list

Use % as a wildcard character (e.g., MSKU% finds ALL containers starting with MSKU)

Can be limited to a specific column by selecting it from the column dropdown

Quick Search is NOT case-sensitive (MSKU = msku = Msku)

Clear Quick Search: delete the text and press Enter to return to the full list

If Quick Search returns no results: check that the attribute you are searching IS visible as a column in the list view.
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1.6 – Quick Search & Filter Panel Screenshots

Both search tools from the training manual

N4 Units list with Quick Search field highlighted – showing wildcard search (MSKU%) being 
entered and filtered results appearing

N4 Filter panel – showing Filter Criteria area with attribute selector, operand dropdown and 
value field with AND/OR grouping buttons

Quick Search = fast wildcard search | Filter Panel = complex multi-criteria saved search (funnel icon)
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biznovate
1.6 – Quick Search & Filter Panel Screenshots

Both search tools from the training manual

N4 Units list with Quick Search field highlighted – showing wildcard search (MSKU%) being 
entered and filtered results appearing

N4 Filter panel – showing Filter Criteria area with attribute selector, operand dropdown and 
value field with AND/OR grouping buttons

Quick Search = fast wildcard search | Filter Panel = complex multi-criteria saved search (funnel icon)
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1.6 – Filter Panel – Advanced Multi-Criteria Search

Opening and using the Filter panel

Steps to Use the Filter Panel

Step 1: Click the Filter icon (funnel ) at the top of the list view to open the Filter Criteria panel

Step 2: Click 'Add Criterion' and select the attribute (field) you want to filter on from the dropdown

Step 3: Select the Filter Operator – operators are CONTEXTUAL based on the field data type

Step 4: Enter the filter value. For multiple criteria, click 'Add Criterion' again.

Step 5: Combine criteria using AND / OR groupings for complex searches

Step 6: Click 'Apply Filter' to execute the search and see filtered results in the list

Filter Operators by Field Type

TEXT fields: Is (=), Matches (== allows %), Contains, Starts With, Is undefined (null), Is defined (not null)

NUMBER fields: Is (=), Is less than (<), Is greater than (>), Is >= , Is <=

DATE/TIME fields: Is before (<), Is after (>)

BOOLEAN (Yes/No) fields: Is (=), Is not (!=)
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1.6 – Parameterising & Saving Filters

Making filters reusable across users and sessions

Parameterising a Filter (Making It Variable)

Open the Filter Criteria panel and select the attribute you want to parameterise

Click 'Parameterize' on that criterion row – this makes it a variable input at runtime

Enter a Parameter Name (e.g., 'Line Operator' or 'Category') to label the prompt

If the value is not required (filter still runs without it), leave Value Required unchecked

Save the filter. When applied in future, N4 will PROMPT the user for the parameter value

One filter serves multiple searches – e.g., 'Yard By Category' prompts each time it runs

Saving & Sharing Filters

From the Filter panel, click 'Save Table View as Filter...'

Give the filter a descriptive Name and Description so other users understand it

If NO Role assigned: filter is PRIVATE to that user only

If a ROLE is assigned: ALL users in that role can see and use the filter

To reuse: click the Filter dropdown (left of Quick Search) and select your saved filter

Saved filters persist between login sessions – they are stored in the N4 databaseBest practice: always assign a Role to shared filters so the whole team benefits. Name filters clearly (e.g., 'Imports In Yard – 20ft').
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1.6 – My List Feature

Bookmarking specific containers for focused monitoring

Purpose Bookmark up to 950 specific units for focused monitoring. Units stay until manually removed.

Add via Inspector Click the '+' button in the Unit Inspector to add that unit to My List

Add via List View Select units in the Units list, then Display → Add Selected to 'My List'

Add via Free Text Operations → Unit → My List → Display → Add (paste container numbers directly)

Remove Display → Remove Selected (removes highlighted units from My List)

Subset View Display → List Selected – creates a temporary subset view of selected rows

Scope – Personal My List is User-ID specific by default (private to the logged-in user)

Scope – Shared Can be shared with a Company/Business Group for team monitoring

My List is the fastest way to monitor a specific set of containers (e.g., containers with holds, priority vessel cargo, customer disputes).
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1.6 – My List Feature (Screenshot)

My List in action – bookmarked containers

My List showing bookmarked containers with total count, Display menu with Add/Remove/List Selected options visible
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Section 1.7

N4 Vessel Operations

Creating Vessels, Visits, Stowplans, Bookings & BLs
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1.7 – Vessel Planning Workflow – 6 Steps

From Service creation to final bay plan export

1

Vessel Service
& Port Rotation

Configuration → Carriers → Carrier 
Services. Define port rotation 
(NGAPP + ports). Max 3-char 

Service ID.

2

Vessel Class

Configuration → Carriers → Vessel 
Classes. Class ID MUST match XPS 

ship file name exactly.

3

Vessel Record

Configuration → Carriers → 
Vessels. Enter Identity, Class, Line 
Operator, Radio Call Sign, Lloyds 

Number.

4

Vessel Visit

Operations → Vessel → Vessel 
Visits. Create visit, advance to 

INBOUND to appear in XPS.

5

Bay Plan
(BAPLIE/Manual)

Import via EDI BAPLIE or manually 
enter via Operations → Vessel → 

Vessel Stow Plan.

6

Export Final
Bay Plan

Export outbound BAPLIE, run vessel 
reports, close the visit.
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biznovate
1.7 – Creating a Vessel Service & Vessel Class

Configuration → Carriers

Creating a Vessel Service

Navigate to: Configuration → Carriers → Carrier Services

Click (+) Add. Enter Service ID (max 3 characters, e.g., JXY where XY = your user number)

Fill ALL mandatory fields (highlighted in GREEN in N4)

Add port rotation: click 'Add Port' and add NGAPP plus several additional ports

Save the service

The Service ID and Port Rotation are READ-ONLY in XPS. All changes must be made in N4.

NEVER delete a service with active vessel visits.

Creating a Vessel Class

Navigate to: Configuration → Carriers → Vessel Classes

Add a new Vessel Class. Make the Class ID match your Service ID (e.g., JXY)

The Vessel Class ID links N4 to the physical XPS ship file (.NSD format)

Naming convention for ship files: <lineop>.<VesselClass>.<VesselName>.nsd

There MUST be an exact match between the Class ID and the ship file naming

Fill in all physical vessel details in the Vessel Class form. Save.

The Class ID → Ship File connection is critical. If the names don't match EXACTLY, the bay plan will be empty in XPS.
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biznovate
1.7 – Vessel Creation Form & Vessel Class Screenshot

From the Training Manual

Vessel creation form showing Vessel Identity, Vessel Class, Line Operator, Radio Call Sign and 
Lloyds Number fields highlighted

Vessel Class form showing the Class ID field and vessel dimensionsRadio Call Sign is used in the TDT segment of BAPLIE EDI files. Lloyds Number is the Lloyd's Register ID.
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biznovate
1.7 – Vessel Record Fields Reference

All key fields when creating a Vessel in N4

Vessel Identity Unique ID for the vessel in N4. Used for EDI (Lloyds Number, Radio Call Sign)

Vessel Class Links to the XPS ship file (.NSD). Must match EXACTLY – case-sensitive.

Vessel Name The official name of the vessel (can differ from the Vessel Identity)

Line Operator The primary shipping line operating this vessel (e.g., MAE = Maersk)

Radio Call Sign The vessel's international radio call sign (used in TDT segment of BAPLIE EDI)

Lloyds Number Lloyd's Register identification number (used in EDI for vessel identification)

Stowage Scheme Controls container stacking rules – usually set to 'Standard ISO'
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biznovate
1.7 – Creating a Vessel Visit

Operations → Vessel → Vessel Visits

Vessel Visit Creation Steps

Navigate to: Operations → Vessel → Vessel Visits

Click (+) Add. Enter a unique Visit Reference code (e.g., USERXY where XY = your user number)

Select the Vessel you just created. Enter inbound and outbound voyage numbers (e.g., 001)

Leave Call Number = 1. Select the Service and Line Operator (MAE). Set Facility = LFT.

Save your new vessel visit

IMPORTANT: Advance the Visit Phase via Actions → Advance Vessel Visit → set to INBOUND

The vessel only appears in XPS ONCE it is set to INBOUND phase

Associating Lines with the Vessel Visit

Lines must be associated with the vessel visit via: Vessel Inspector → Details → Lines Tab

Bookings for lines NOT associated with the vessel visit will be REJECTED at the gate

Association is required before any gate transactions can be processed against this visit

Multiple lines can be associated with one vessel visit (common for slot-charter vessels)
After advancing to INBOUND, go to Actions → Arrive Vessel to record the physical arrival of the vessel at berth.
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biznovate
1.7 – Vessel Visit Phases Reference

Phase transitions and what each enables in N4/XPS

INBOUND Vessel appears in XPS for planning. Discharge planning can begin. Containers visible for pre-planning.

WORKING Needed to properly dispatch containers and record actual moves via XPS/CTUI.

DEPARTED Required to depart outbound Export containers from the facility via gate transactions.

CLOSED Vessel and remaining containers removed from XPS view. Used for billing finalisation.

Arrive (action) Confirms physical arrival of vessel at berth. Changes transit state of onboard containers to INBOUND.

Line Association Vessel Inspector → Details → Lines Tab. Required before gate bookings will be accepted.
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biznovate
1.7 – Stowplan, Discharge & Booking Screenshots

From the Training Manual

Vessel Stow Plan entry – manually adding containers to bay positions (050182, 050184, 
050186) with Equipment Type 22G1, Line MAE

Discharge screen – selecting containers from stowplan and entering yard slot positions
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biznovate
1.7 – Manually Entering a Stowplan

Operations → Vessel → Vessel Stow Plan

Steps to Add Containers to the Stow Plan

Navigate to: Operations → Vessel → Vessel Stow Plan

Add a new container to the stow plan. Enter a bay position (e.g., 050182, 050184, 050186)

Bay position format: BBBRRTT → Bay=050, Row=01, Tier=82 (7 digits total)

Enter your vessel visit reference. Create a new Equipment number (container ID).

Set Equipment Type = 22G1 (20ft GP dry). Set Line Operator = MAE. Set Freight Kind = FCL.

Enter a gross weight (e.g., 14000) and set POD = NGAPP.

Save. View the newly created container in Operations → Unit → Units. Repeat for 3 containers.

Discharging Containers

Confirm the Vessel Visit is in WORKING or INBOUND phase before discharging

Navigate to: Operations → Vessel → Discharge

Select the containers from your vessel and discharge them

Enter a valid yard slot (e.g., 3H01-09 A.1–G.1 as directed by trainer)

Use the Unit Inspector → Event History tab to verify – confirm a UNIT_DISCH event is recorded

Container transit state will change: LOADED → EC-IN → YARD (after yard slot assignment)

After discharge the unit moves to EC-IN state (not yet YARD). It reaches YARD state when a yard slot position is confirmed.
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biznovate
1.7 – Booking Creation Screenshots

Creating Export Bookings from the manual

Export Booking creation form – Line Operator, Vessel Visit, POD, POL, Freight Kind fields Booking Items section – Quantity 20, ISO Group 22G1, Length 20', Height 8'6"PRESS SAVE first before adding Booking Items. Note the Booking Number for gate exercises on Day 3.
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biznovate
1.7 – Booking Creation Screenshots

Creating Export Bookings from the manual

Export Booking creation form – Line Operator, Vessel Visit, POD, POL, Freight Kind fields Booking Items section – Quantity 20, ISO Group 22G1, Length 20', Height 8'6"PRESS SAVE first before adding Booking Items. Note the Booking Number for gate exercises on Day 3.
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biznovate
1.7 – Booking & Bill of Lading Reference

Key fields and concepts for bookings and BLs

Navigate to Bookings Operations → Vessel → Bookings (or Operations → Vessel Mode)

Line Operator Set to MAE. Select your Vessel Visit. Set POD from port rotation. POL = NGAPP. FK = FCL.

SAVE First ALWAYS press SAVE on the booking header BEFORE adding Booking Items

Booking Items Quantity=20, ISO Group=22G1, Length=20', Height=8'6". Note your Booking Number.

Booking Tally Out Maximum number of MTs (empties) that can go out at one time against this booking

Booking Tally In Count of containers already in the yard against this booking

EDI Creation Bookings can be created via EDI (COPARN message from carrier) or manually

Navigate to BLs Operations → Unit → Bills of Lading → (+) to create new BL

BL Setup Set Vessel Visit, POD=NGAPP, POL=another port in rotation, Line=MAE. Save then add a container.
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biznovate
1.7 – Bill of Lading Screenshots

BL creation from the training manual

Bill of Lading creation form showing Vessel Visit, POD, POL, Line Operator fields Bill of Lading with container association – linking import containers to the BLSave the BL header FIRST, then add a container to the BL – use one of the import containers created earlier.
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biznovate
1.7 – Bill of Lading Screenshots

BL creation from the training manual

Bill of Lading creation form showing Vessel Visit, POD, POL, Line Operator fields Bill of Lading with container association – linking import containers to the BLSave the BL header FIRST, then add a container to the BL – use one of the import containers created earlier.
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biznovateHANDS-ON EXERCISE DAY 1

1.  Log in to N4 with your assigned training account (user01–user08). Select the correct Facility (LFT) when prompted.

2.  Switch between OPERATIONS, CONFIGURATION and ADMINISTRATION modes. Identify 3 menu items in each mode and note their purpose.

3.  Navigate to Operations → Unit → Units. Record the total unit count shown in the tab header.

4.  Sort the Units list by Type ISO (ascending). What is the first equipment type? Sort descending.

5.  Remove the 'Last Move' column from the Units list. Add the 'Is OOG' column. Are there any OOG containers?

6.  Use Quick Search to find all containers with Line Operator MAE. Record the count. Then use MSKU% wildcard.

7.  Open the Filter panel. Create: Transit State = YARD AND Category = IMPORT AND Nominal Length = 20. Record the count.

8.  Parameterise the Category attribute in your filter. Save the filter as 'UserXY_YardByCategory'. Run it selecting EXPORT.

9.  Select 5 containers from the Units list and add them to your My List. Confirm they appear in Operations → Unit → My List.

10.  Open the Unit Inspector for one listed container. Identify Visit State, Transit State, Category and current yard position.

11.  Create Vessel Service JXY (NGAPP + 3 ports). Create Vessel Class JXY. Create Vessel JXY (Class JXY, Line MAE, Radio Call Sign XYCall).

12.  Create Vessel Visit USERXY. Advance to INBOUND. Associate Line MAE. Arrive the vessel.

13.  Manually add 3 containers to your stowplan at positions 050182, 050184, 050186 with Equipment Type 22G1.

14.  Discharge the 3 containers to yard slot 3H01-09 A.1. Use Unit Inspector → Event History to confirm UNIT_DISCH is recorded.

15.  Create Export Booking for 20×22G1 on your vessel visit. Create a Bill of Lading and associate one import container.

Biznovate Technologies Limited  |  NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal



DAY

2
SPARCS N4 Basic Administration

Reference Data | Services & Events | Holds/Permissions | 
Business Rules | Unit Admin | Security | Flex Fields

biznovate

T O D A Y ' S  A G E N D A

1.  Reference Data – Equipment Types, Features, Grades, Prefixes

2.  Equipment Damage Types, Components, Ranges & Equivalents

3.  Reference Data – Routing, Cargo & Organisations

4.  N4 Events – Built-in vs User-Defined

5.  Defining Event Types & Effects Configuration

6.  Auto-Update Rules

7.  Holds – Definition, Configuration & Application

8.  Permissions – Definition & Configuration

9.  Viewing Holds & Permissions in the Units List

10.  Business Rule Types – Simple, Guardian, Guarded, Prerequisite

11.  Service Business Rule Form

12.  Storage Rules Configuration

13.  Unit Administration Functions

14.  Security – Roles, Privileges & Users

15.  Business Groups & Delegated Security

16.  User Monitor & Authentication History

17.  N4 System Settings

18.  Fields (Flex Fields) Configuration

19.  Day 2 Lab Exercises



biznovate
2.0 – Day 2 Overview – SPARCS N4 Basic Administration

From the Training Manual

Day 2 overview: SPARCS N4 Basic Administration – Reference Data, Services, Events, Unit Admin, Security, Settings & Flex Fields

NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited DAY 2



biznovate
2.0 – Day 2 Content Map

Administration topics and their organisation

Content map showing SPARCS N4 Admin Basics: Reference Data, Services, Unit Admin, Security, Settings and Fields sections
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Section 2.1

Reference Data

Equipment, Routing, Cargo & Organisations

biznovate DAY 2



biznovate
2.1 – Equipment Reference Data

Configuration → Equipment

Equipment reference data: Equipment Types (ISO codes, 22G1 = 20ft GP dry), Features, Grades, Prefixes, Damage Types, Damage Components, Ranges, Type Equivalents
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biznovate
2.1 – Equipment Reference Data Reference

All equipment reference data entities in N4

Equipment Types ISO container type codes (e.g., 22G1 = 20ft GP dry). Most predefined. Scope-level defined.

Equipment Features Special physical characteristics: Aluminium, Wooden Floor, Side Door. Assigned to equipment types.

Equipment Grades General condition: Clean, Washed, Out of Service, Grade A/B/C.

Equipment Prefixes Assign container number prefixes to Line Operators. Configure check-digit algorithm per prefix.

Damage Types Physical damage classifications: Hole, Rust, Wound, Dent. Used in N4 Mobile/Unit Inspector.

Damage Components Location of damage: Front Wall, Left Side, Corner Post, Roof.

Equipment Ranges Auto-tag a set of equipment of the same type (e.g., all containers in a number range = reefers).

Type Equivalents Groups interchangeable containers for booking/delivery (e.g., 45ft 9'0" ≡ 45ft 9'6"). Can be line-specific.
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biznovate
2.1 – Routing & Cargo Reference Data

Configuration → Routing and Cargo entities

Reference Data – Routing: UN Locations, Routing Points (vessel rotation ports, rail hubs), 
Groups (discharge import groupings)

Reference Data – Cargo: Commodities, Special Stow (ADK, OOG), Hazard Placards, Package 
Types for BLs
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biznovate
2.1 – Organisations Reference Data

Configuration → Organizations

Organisations: Master Organisation, Line Operators (BIC/SCAC for EDI), Trucking Companies, 
Shippers/Consignees, Agents

Organisation relationships: how sub-organisations link to Master Org; Line Operators with 
SCAC/BIC codes

Line Operators must have the correct BIC or SCAC code for EDI message identification.
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biznovate
2.1 – Organisations Reference

All organisation types and their purpose

Master Organisation Top-level entity. Multiple sub-organisations can be linked to one Master Org.

Line Operators Shipping lines. Identified by BIC or SCAC code for EDI. Link Agents, Storage Rules, Booking Rules per line.

Trucking Companies Truck operators that can call the terminal. Link drivers and agents to the trucking company.

Shippers/Consignees Used in Bills of Lading for cargo ownership and documentation.

Agents Representatives for lines, trucking companies, shippers. Linked to the Master Organisation.

Railroad Operators Rail carriers. Link to Master Org, define agents for the railroad operator.
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biznovateHANDS-ON EXERCISE DAY 2 (SECTION 2.1)

1.  Create an Equipment Feature named 'DRINGXY' (XY = your user number).

2.  Create an Equipment Grade named 'RinsedXY'.

3.  Create an Equipment Prefix 'NGXY' and assign it to your designated Line Operator.

4.  Create a Damage Type named 'DentXY'.

5.  Create a Damage Component named 'Corner Post – CPXY'.

6.  For your assigned Line Operator, create a 45ft Equipment Type Equivalent so that 9'0" and 9'6" high cube containers are interchangeable.
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Section 2.2

Services

Events, Auto-Update Rules, Holds, Permissions, Business Rules

biznovate DAY 2



biznovate
2.2 – N4 Events Overview

Built-in vs User-Defined Events

Events overview showing Built-in Events (UNIT_DISCH, UNIT_LOAD, GATE_IN – cannot be 
disabled) and User-defined Service Events

Events table: Entity Types, Built-in events (Is Traced only modifiable), User-defined events 
configuration path
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biznovate
2.2 – Defining Event Types – Form Screenshots

Configuration → Services → Event Types

N4 Event Type definition form – Entity Type, Billable/Notifiable checkboxes, Filter Criteria tab 
visible

N4 Event Type form – Effects configuration tab showing Is Traced, Is Updated, Is Required, Is 
Auto-Updated, Automatic Value settings
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biznovate
2.2 – Event Type Fields Reference

All fields when creating a user-defined Event Type

Entity Type Which entity this event applies to: Unit (most common), Equipment, Booking, Vessel Visit, etc.

Billable If checked, the event is extracted to the N4 Billing table for invoicing when recorded

Notifiable If checked, N4 can send email notifications when this event is recorded

Bulk-Applied If checked, the event can be applied to multiple entities at once

Filter Restricts which entities this event can be applied to (e.g., only imports in yard, only empties)

Is Traced (Effect) Creates an audit record in the Event History when this field is updated

Is Updated (Effect) Field CAN be edited by the user when recording the event

Is Required (Effect) User MUST provide a value before the event can be saved

Is Auto-Updated (Effect) N4 automatically sets this field to the Automatic Value when the event fires

After enabling a new Effect, click Actions → Reset in the Event Types screen, then re-record the event to see changes.

NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited DAY 2



biznovate
2.2 – Auto-Update Rules

Configuration → Services → Auto-Update Rules

Auto-Update Rule example: UNIT_DAMAGED event fires AND Damage Severity = Major → Grade updated to OUT OF SERVICE + Repair Hold applied automatically
Auto-Update Rules automate field updates and hold/permission actions when specific BUILT-IN events occur (the mechanism for built-in events where Effects cannot be 

added directly).
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biznovate
2.2 – Holds & Permissions Explained

Two mechanisms to control container operations

HOLDS – Prevention Mechanism

A Hold PREVENTS a specific service event from being performed on the unit

Applied MANUALLY by a user (or automatically via Auto-Update Rule)

Must be RELEASED before the blocked service event is allowed to proceed

STOP icons in Units list = active Holds that prevent vessel/rail/road operations

Can be placed on a GUARDIAN entity (e.g., Quarantine Hold on a vessel prevents discharge of ALL containers)

Reference ID: used when same Hold is needed for multiple purposes – allows releasing each individually

Billing Hold flag: required for Payment Holds (preventing gate-out until payment is made)

PERMISSIONS – Authorisation Mechanism

A Permission GRANT must be present BEFORE a specific service event is allowed

Applied AUTOMATICALLY by N4 via Business Rule (or can be granted/cancelled manually)

Example: Customs Release permission must be granted before delivery (UNIT_DELIVER) is allowed

! Impediment icons in Units list = Permissions that have NOT yet been granted

SLOW Impediments are calculated on-the-fly – may slightly slow down the list display time

Reference ID: allows releasing each purpose for the same Permission individually

HOLD = STOP sign. PERMISSION = GREEN LIGHT that must be switched on before proceeding.
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biznovate
2.2 – Business Rule Types Screenshot

Service Business Rule form from the Training Manual

N4 Service Business Rule form – showing Rule Type selector (Simple/Guardian/Guarded/Prerequisite), Service Event Prevented and filter criteria panelConfiguration → Services → Service Business Rules → Service Business Rules view → Service Business Rule form
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biznovate
2.2 – Business Rule Types Reference

All four business rule types with examples

SIMPLE Hold/Permission applies DIRECTLY to the entity itself (the container). Most common type. 1:1 relationship.

GUARDIAN
Hold placed on PARENT entity prevents operations on ALL its children. Example: Quarantine Hold on a Vessel → ALL 
containers on that vessel blocked from discharge.

GUARDED
Hold/Permission applies ONLY for a specific relationship. Example: Customs Release for Vessel Visit ABC123 only – if 
container rolls to a new vessel, a NEW permission is required.

PREREQUISITE
A specific service event must be recorded BEFORE the blocked event is allowed. Example: Cannot strip until 
'Fumigation Inspection' service event has been recorded.

Rule Limit Adding more than 250 service business rules can impact N4 performance – review periodically.

Config Path Configuration → Services → Service Business Rules → Service Business Rules view

Business Rules use Holds or Permissions to enforce process compliance. They control WHEN an event is allowed to occur.
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biznovate
2.2 – Storage Rules Screenshot

Configuration → Services → Storage Rule Types

Storage Rule Types configuration showing Start Day Rule, End Day Rule, Include Gratis Days, Power Charges (Reefer power)  settings
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biznovate
2.2 – Storage Rules Reference

Configuration → Services → Storage Rule Types

Set Per Line Different storage rules can be configured per Line Operator (different free time terms)

Start Day Rule When free time counter begins: Yard IN Time | I/B Discharge Complete | First Available Day

End Day Rule When free time counter ends: Yard OUT Time | O/B Carrier Start Work | O/B Visit ETA

Include Gratis Days Should holidays count as free days? Configure via Configuration → Other → Calendar

Power Charges Reefer power: Start/End Day Cut-off Hours, Power Charge by Hour or Day, Tier Rounding rules

Storage Rules defined here feed into N4 Billing (Day 5). They control demurrage calculation for each Line Operator.
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biznovateHANDS-ON EXERCISE DAY 2 (SECTION 2.2)

1.  Create user-defined Event Type '[FirstName] Inspection'. Set it to apply to Units, make it Billable. Add Filter: Imports in the Yard only.

2.  Add Effects: (a) Special Stow 1 – Required, Updated, Traced. (b) Unit Notes – Auto-Updated with '[FirstName]Insp was recorded'. (c) 
Equipment Grade – Auto-Updated to CLEAN, Traced.

3.  Record your Inspection event against an Import in the Yard. Review Event History – confirm Grade and Notes were updated.

4.  Create Hold 'USERXYHold'. Create Simple Business Rule 'USERXYHoldRule' preventing UNIT_LOAD. Apply hold to an Export. Attempt to load –
confirm the error message.

5.  Create Permission 'USERXYPerm'. Create Simple Business Rule preventing UNIT_DELIVER for Imports. Confirm ! impediment appears. Grant it, 
then cancel it.

6.  Create Auto-Update Rule 'USERXYAutohold': trigger = [FirstName] Inspection event fires → auto-apply USERXYHold.

7.  Create Prerequisite Business Rule: UNIT_STRIP blocked until '[FirstName] Inspection' has been recorded. Test against a discharged container.

8.  Create Storage Rule: Start = Yard IN, End = Yard OUT, 3 free days for IMPORT on your Line Operator. View storage info in Unit Inspector.
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Section 2.3

Unit Administration

Data Correction & Lifecycle Management

biznovate DAY 2



biznovate
2.3 – Unit Administration Functions Screenshot

Actions → Administration menu

Unit Administration functions: Unit Details Editor, Rectify Unit, Renumber Unit, Depart Units, Cancel Preadvised, Resurrect Delivered, Update VisibilityRectify Unit and Unit Details Editor have LIMITED validation – bypass normal business rules. Always document reason and get supervisor approval.
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biznovate
2.3 – Unit Administration Functions Reference

All unit admin functions and when to use them

Unit Details Editor
Actions → Update → Show Unit Details Editor. Bulk edit unit attributes. Limited validation. Checkbox with no 
value = sets field to NULL.

Unit Refresh
Recalculates unit impediments (holds/permissions). Via background job 'Launch Unit Maintenance Jobs'. Frequency: 
INVREFRESH001/002/003.

Rectify Unit
Actions → Administration → Rectify Unit. Corrects bad data or undoes an event. Bypasses business rules. 
CAUTION – document and get supervisor approval.

Renumber Unit
Actions → Administration → Renumber. Changes container number. Respects check-digit calculations. Updates all 
Chargeable Unit Event records.

Depart Units Forces a unit to depart if loaded onto outbound carrier but state not automatically updated.

Cancel Preadvised
Deletes Advised or Inbound state units not yet arrived at the facility. Only works for Advised or Inbound transit 
state.

Resurrect Delivered Creates new Advised unit-facility-visit so departed unit can be received back (Dray-in scenario).

Update Visibility Actions → Administration → Update Visibility. Make unit Visible/Not Visible in SPARCS XPS.
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Section 2.4

Security Administration

Roles, Privileges, Business Groups & Delegated Security

biznovate DAY 2



biznovate
2.4 – Security Privileges & Roles

N4 is role-based – privileges assigned to Roles, Roles assigned to Users

Security administration: Privilege types (Static, Dynamic, Constrained), Roles and how 
they are assigned to users

N4 Security – Roles & Privileges

KEY RULE: Privileges → Roles → Users. NEVER assign privileges directly to users.

Static Privileges: Built into N4. Relate to work modes, menu options and actions 
(View, Add, Edit, Delete). Example: 'Vessel Visits – Edit'.

Dynamic Privileges: Created for configurable components. Examples: Gate Stages, 
Hold Add, Hold Release, Permission Grant, Permission Cancel.

Constrained Privileges: Standard privilege restricted to a specific organisation. 
Example: 'Unit Actions – Renumber constrained by Line Operator' – user can only 
renumber containers belonging to their line.

Role: A named group of privileges. Roles are assigned to users. A user can have 
MULTIPLE roles.
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biznovate
2.4 – Security Screenshots

From the Training Manual

Security Administration overview showing privilege types, role management interface Role creation form showing privilege list and assignment of privileges to a role
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biznovate
2.4 – More Security Screenshots

Role and user management

User management screen showing user list and user creation/role assignment interface Additional security configuration showing role privileges and constrained privilege setup
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biznovate
2.4 – Business Groups & Delegated Security

Data visibility control and delegated administration

Business Groups: affiliated to companies, users see only entities affiliated with companies in their group; Constrained privileges restrict actions within scope
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biznovate
2.4 – Business Groups Reference

How Business Groups control data visibility

Business Groups Control data VISIBILITY. Navigate to: Administration → Security → Business Groups.

Affiliation Groups are affiliated to companies (Line Operators, Trucking Companies, etc.)

Visibility Rule Users associated with a group can ONLY see entities affiliated with companies in that group

Multi-Company A booking/container may relate to several companies – user must represent AT LEAST ONE to view it

Constrained Privilege Further restricts which actions the user can perform on entities within their Business Group scope

Super Admin Creates the Delegated Admin Role and assigns it to the Delegated Admin user

Delegated Admin Can create additional roles (derived from Delegated Admin Role), create users and assign them to those roles

Inherited Roles Derived roles and users are TIED to the Delegated Admin Role – revoking it removes ALL derived access

Test user for Delegated Security exercise: username = delegator / password = gator
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biznovate
2.4 – User Monitor & Authentication History

Administration → Security

Current Users Monitor: shows all users currently logged in, when they logged in and at what scope level. Authentication History: log of all login attempts.
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Section 2.5

N4 Settings & Flex Fields

System Configuration & Custom Fields

biznovate DAY 2



biznovate
2.5 – N4 System Settings Screenshots

Administration → Settings → Settings

N4 Settings overview showing 400+ configurable settings that control terminal behaviour
N4 Settings screen showing scope override capability (Operator → Complex → Facility level 

overrides)
Changing N4 Settings affects ALL users at that scope level. Always test in test environment first.
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biznovate
2.5 – N4 Settings Reference

Key settings categories and their purpose

Scope Override Settings can be set at Operator level and overridden at Complex or Facility level

Min/Max Values Some settings have hard-coded min/max values (e.g., password length 5–20 characters)

INVREFRESH001-003 Controls frequency of Unit Impediment recalculation (Unit Refresh background jobs)

Gate Settings Control appointment requirements, transaction timeouts, gate stage behaviour

Vessel Settings Control visit phase transitions, bay plan import rules, load/discharge validation

N4 has 400+ settings Covering all aspects of terminal operations, security, EDI, billing and reporting

Changing N4 Settings affects ALL users and operations at that scope level. ALWAYS test changes in the test environment first and obtain change management approval 
before modifying production settings.
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biznovate
2.5 – Flex Fields Overview

Administration → Settings → Fields

Flex Fields: pre-defined placeholder fields in the N4 database for customisation without system development. Shows scope, importance, Short/Long names, Group IDs, LOV 
configuration.
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biznovate
2.5 – Flex Field Group IDs – Where They Display

Unit Flex Field Group ID reference

Unit Flex Field Group IDs – showing where each Group ID places the field in the N4 Unit 
Inspector tabs

Unit Flex Field Group IDs (continued) – all group positions and their corresponding N4 UI 
locations

NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited DAY 2



biznovate
2.5 – Flex Field Group IDs (Continued)

Additional Group ID placement reference

Unit Flex Field Group IDs – complete reference showing all Group IDs and where they display in N4After enabling a Flex Field: click Actions → Reset in the Fields screen, then re-open the relevant N4 tab. The field will NOT appear until the tab is refreshed.
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biznovateHANDS-ON EXERCISE DAY 2

1.  Create Security Role named after your last name. Assign: Units View, Vessel Visits View, Vessel Visits Inspect, Vessel Visits Actions – Edit Port 
Rotation.

2.  Create a new User and assign them to your new Role. Log in as the new user in a new browser session. Verify the restricted menu options.

3.  Log in as the delegator/gator user. Create a delegated role and demonstrate the difference in the Users/Roles management interface.

4.  Create a Business Group named 'YourName Alliance'. Assign Line Operators CMA and MSC. Add the group to your new user.

5.  Log in as the new user – verify you can ONLY see CMA and MSC containers in the Units view.

6.  Create a Constrained Privilege: Unit Actions – Renumber constrained by Line Operator. Add it to your role. Test that renumbering an MSC 
container works but renumbering a CMA container is blocked.

7.  Navigate to Administration → Settings → Fields. Filter to Custom Fields only.

8.  Find unitFlexStringXX (XX = your user number). Click Override, set to Optional. Set Short Name='UsrXX Notes', Long Name='Terminal UsrXX 
Note'. Group ID 4-Contents. Save.

9.  Click Actions → Reset. Re-open Units tab. Confirm you can enter a value for your flex field in the Shipment Details.

10.  Add 3 List of Values (LOV) options. Confirm the input now shows a dropdown selector.

11.  Change Group ID to 9-Other. Re-open Units tab. Where does your flex field now appear?
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DAY

3
N4 Mobile | Gate Config | Licensing | XPS

RDT/Yard Inspection | Reefer Monitor | Gate Configuration | 
Licensing | XPS User Admin | Equipment Setup

biznovate

T O D A Y ' S  A G E N D A

1.  N4 Mobile (RDT) – Overview & Architecture

2.  N4 Mobile Login Screen & Operational Roles

3.  Yard Inspection – All Shortcut Keys (D/R/S/H/O/B/W/A/E)

4.  Reefer Monitoring – Power Status Colour Codes

5.  Reefer Work List

6.  Gate Configuration Overview (3.2)

7.  Gates View (3.2.1) – Adding & Managing Gates

8.  Gate Configurations View (3.2.2) – Hierarchy

9.  Gate Transaction Processing Flow (8 Steps)

10.  Gate Business Task Types (3.2.3)

11.  Configuring Gate Business Tasks

12.  Gate Business Tasks Reference Table

13.  Gate Transaction Types (RF/DI/RM/DM + combos)

14.  Gate Appointment Rules (3.2.3)

15.  Setting Up Gate Printer (2.4)

16.  Gate Documents (2.5)

17.  N4 Licensing – How It Works (3.3)

18.  Viewing & Downloading the Current Licence

19.  Uploading & Activating a New Licence

20.  XPS Administration – Overview & Relationship to N4

21.  XPS User Administration

22.  XPS Role/Privilege Management

23.  Creating Equipment in XPS (RTG, STS, RS, EH, YT)

24.  Creating Pools & Points of Work (POW)

25.  Updating the XPS Sparcs Settings File

26.  Updating XPS Licences

27.  Accessing the Ship File in XPS

28.  Day 3 Lab Exercises



Section 3.1

N4 Mobile (RDT Option)

Overview, Architecture & Operational Roles

biznovate DAY 3



biznovate
3.1 – N4 Mobile Overview & Architecture

Overview & RDT Communications from the Training Manual

N4 Mobile overview showing N4 Mobile Options and the RDT Communications Radio Server chain: Host/Server → Radio Server → Radio Controller → Radio Frequency Unit → Vehicle 
Mount RDT + Hand-held RDT
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biznovate
3.1 – N4 Mobile Overview & Access Details

Key facts about the N4 Mobile interface

Access Method Browser-based mobile interface optimised for small screens and handheld devices

URL http://[server]:9080/apex/entry.faces (same credentials as N4 desktop)

Login Scope Operator: APMT, Complex: NGAPP, Facility: PTM, Yard: PTM (Training: use LFT)

Architecture N4 Mobile → Radio Server → Radio Frequency Unit → Handheld/VMT device chain

User Setup Users defined in N4, linked to a Role with specific N4 Mobile privileges

Shortcut → Login Navigation shortcut button returns you to the login screen

Program Screen Navigation shortcut button takes you to the Program/Function selection screen

Go Button Jump shortcut to specific program screens

Real-Time Sync All changes via N4 Mobile are reflected IMMEDIATELY in N4 desktop and XPS
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biznovate
3.1 – N4 Mobile Login Screen & Program Selection

From the Training Manual

N4 Mobile login screen showing User ID, Password, Send button and Site Selection screen 
with Operator/Complex/Facility/Yard

N4 Mobile Program screen showing: Reefer Monitor(m), Yard Inventory(i), Gate 
Inspection(g), Rail Operations(r), Rail Inventory(x), Depot Hatch Clerk(d), Hatch Clerk(h)
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biznovate
3.1 – N4 Mobile Operational Roles

All roles, functions and key screens

Yard Clerk
Update Yard Inventory, Damages (D), Reefer (R), OOG (O), Hazards (H), Seals (S), Bundles (B), Weights (W), Event 
Recording (E) → Yard Inspection screen

Reefer Clerk
Connect/Disconnect reefer orders, Monitor temperatures, Update Desired State (On/Off Power) → Reefer Monitor 
screen

Gate Clerk Same as Yard Clerk PLUS Update Truck Details → Gate/Rail Inspection screen

Rail Clerk Update RailCar Inventory, same as Yard Clerk functions, Record Rail Discharges/Loads → Rail Inventory screen

Hatch Clerk
Record Vessel Loads/Discharges, Vessel Shifts, Inspections (seals, damages), Create Orphan containers → Hatch 
Clerk screen
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biznovate
3.1 – Yard Inspection – All Shortcut Keys

After entering container number in Yard Inspection, use these shortcuts

Complete Yard Inspection Shortcut Key Reference

(D) – Record Damage: enter damage type, component and severity. Creates damage record in N4.

(R) – Update Reefer details: temperature, vent setting, humidity. Updates reefer record.

(S) – Record/Update Seal numbers: Seal 1 and Seal 2. Updates seal fields on the container.

(H) – Record/Update Hazard information: IMDG class, placard number.

(O) – Record Out of Gauge (OOG) dimensions: height, width and length overhangs.

(B) – Bundle container details.

(W) – Update gross weight. Updates the weight field on the container.

(A) – Additional functionality: Set Grade, Material and other attributes.

(E) – Event Recording: record a user-defined service event from the field.

(P) – Record Placard for Export (dangerous goods containers).

Reefer Power Status Colour Codes in N4 Mobile

ON POWER (I) – RED: Container IS on power but SHOULD be unplugged Action required

ON POWER (I) – YELLOW: Container IS on power and should remain plugged in ✓ Correct state

OFF POWER (O) – GREY: Container is OFF power and should remain unplugged ✓ Correct state

OFF POWER (O) – RED: Container is OFF power but SHOULD be plugged in Action required

Reefer Work List

Container appears on Reefer Work List if Desired State does NOT match On Power status

C on the work list = reefer not connected but SHOULD be connected

D on the work list = reefer connected but SHOULD be disconnected

Monitoring Times defined in N4 via Configuration → Services → Auto-Update Rules
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Section 3.2

Gate Configuration

Gates View, Configurations, Business Tasks & Transaction Types

biznovate DAY 3



biznovate
3.2 – Gate Configuration Overview

Configuration → Gate → Gates → Gates view

N4 Gates view showing list of gates at the current scope level. Options to add new gates and edit/delete existing gates. Gate properties: type, direction, active status.
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biznovate
3.2 – Gate Configuration Overview

What N4 gate configuration supports

Purpose Configure gates to support all gate operations needed at a marine container terminal

One-Stage Ingate Configurable single-stage ingate for simple gate operations

Multi-Stage Ingate Multiple ingate stages (IN → INTERMEDIATE → OUT) for complex operations

Ingate/Outgate Configurable one-stage or multistage ingate AND outgate

Optional Bookings Gate transactions can validate against optional bookings

Record Damages Ability to record damages, seals, hazards, and OOG information at the gate

Gate View Path Configuration → Gate → Gates → Gates view

Multiple Configs Multiple gate configurations can be added for one operator (full gate, empty gate, etc.)

To view a graphical representation of the gate configuration steps, see the Gate Configurations view (Configuration → Gate → Gate Configurations).
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biznovate
3.2.2 – Gate Configurations View

Configuration → Gate → Gate Configurations

What the Gate Configurations View Provides

Displays ALL gate configurations defined for the operator

Add, edit, delete gate configurations, gate stages, truck visits, and gate transaction types

Add an appointment stage for a gate configuration that uses appointments

Actions Available on Gate Configuration

Import Gate Configuration: import from another operator or N4 instance (use this to import to production after testing)

Export Gate Configuration: export as XML file for other operators or N4 instances

Validate Gate Configuration: check for missing mandatory fields, missing business tasks, valid next gate stage

Requires 'Gate Configuration Validation' privilege in your role to see the Validate option

Recover Obsolete: recover deleted gate configurations

A Gate Configuration Defines

The ingate and outgate STAGES

A TRUCK VISIT FORM for each gate stage

The GATE TRANSACTION TYPE FORMS for each gate stage

The BUSINESS RULES for each gate transaction type

An APPOINTMENT STAGE and associated appointment transaction type forms

Before selecting any action, ensure the gate configuration NODE is selected in the left pane. If wrong node selected, N4 displays an error.
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biznovate
3.2.2 – Gate Configuration Hierarchy Screenshot

N4 Gate Configuration view from the Training Manual

N4 Gate Configurations view showing hierarchy: Gate Configurations tree with PA GATE, PA OLD, KO GATE, LP GATE under Operator APMTThe hierarchy shows: Gate Configuration → Stages → Transaction Types → Business Tasks
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biznovate
3.2 – N4 Gate Transaction Processing Flow

8-step sequence from truck pre-advice to CODECO EDI

1

Pre-Advice
/ Appointment

Truck Pre-Advice created in N4 via 
EDI COPINO or manually by gate 

operator

2

Truck Arrives
at Gate

Operator scans truck licence plate / 
driver ID at IN Stage

3

N4 Matches &
Validates

N4 matches truck to pre-advice and 
validates the transaction type 

selected

4

IN Stage
Business Tasks

Booking validated, holds checked, 
seals recorded, damage inspected

5

Intermediate
Stage(s)

Weight bridge, OCR scanning, 
customs inspection (if configured)

6

OUT Stage
Business Tasks

Transaction confirmed, unit transit 
state updated, gate ticket printed

7

Transit State
Updated

Unit T-state updated in real time: 
RECEIVED → YARD state or EC-OUT 

→ DEPARTED

8

CODECO EDI
Generated

CODECO EDI message generated 
and sent to carrier/customs (if 
outbound session configured)
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biznovate
3.2.3 – Gate Business Task Configuration Screenshot

From the Training Manual

N4 Gate Business Task configuration showing Stage selected, Business Task type dropdown, Sequence number field, Required/Optional (Included/Excluded) toggle visibleNavigate to: Configuration → Gates → Gates → select gate → Stages tab → select Stage → Business Tasks tab
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biznovate
3.2.3 – Configuring Gate Business Tasks

The core engine of automated gate processing

What Gate Business Tasks Are

Configurable automated actions triggered at specific gate stages during transaction processing

Define what N4 automatically does at each stage: validate bookings, record damage, print tickets, update transit states, send EDI

Business Tasks are the CORE ENGINE driving automated gate processing in N4

Configuration Steps

Navigate to: Configuration → Gates → Gates → select gate → Stages tab → select Stage → Business Tasks tab

Click Save. The task now executes automatically when a truck reaches this stage.

Set whether the task is INCLUDED (failure stops the entire transaction) or EXCLUDED (not required)

Configure the task parameters (each task type has specific settings)

Hands-On Exercise

Open N4 Gates and create a new gate

Navigate to Gate Stages → Ingate → DI → Include Storage Paid Through Date → set Grace hour to 12hrs

Open the printer form → Create a new printer for outgate and assign necessary IP address with correct Description

Identify 4 business tasks in any gate form and explain their uses when Included or Excluded

Business Tasks determine HOW the gate processes each truck visit. Getting these right is critical to gate operations.
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biznovate
3.2.4 – Gate Transaction Types Reference

What N4 validates for each transaction type

RECEIVE EXPORT (RE)
Container received INTO terminal. Category=Export/Transship. Unit→YARD. Validated against pre-advice, booking 
or BL.

DELIVER IMPORT (DI) Container delivered OUT to customer. Category=Import. Validated against BL. Unit→DEPARTED.

RECEIVE EMPTY (RM) Empty container received INTO terminal. Validated against ERO or line operator empty receive authority.

DELIVER EMPTY (DM) Empty container delivered OUT. Validated against EDO or booking. Unit→DEPARTED.

RECEIVE FULL / DELIVER FULL Combination: truck drops off full container AND picks up full container in one gate visit.

RECEIVE EMPTY / DELIVER EMPTY Combination: truck drops off empty AND collects empty in one gate visit.

RECEIVE FULL / DELIVER EMPTY Combination: truck delivers full export AND collects empty on exit.

RECEIVE EMPTY / DELIVER FULL Combination: truck drops off empty AND collects full import for delivery.

An incorrect transaction type will cause validation failures and prevent the transaction from completing. Always confirm with the truck driver before processing.
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biznovate
3.2.3 – Gate Appointment Rules Reference

Configuration → Gates → Gate Appointment Rules

Appointment Required YES = truck cannot gate-in without a valid appointment. Trucks without appointments are rejected.

Appointment Window (mins) Minutes before/after the appointment slot when a truck is still accepted for processing.

Max Trucks Per Slot Maximum number of trucks that can hold appointments in a single time slot.

Slot Duration (mins) Length of each appointment time slot (e.g., 15, 30 or 60 minutes).

Gate Operating Hours Operating hours for the gate. Trucks arriving outside these hours are rejected.

Pre-Advice Required When YES, a truck cannot gate-in without a matching pre-advice (COPINO or manual) in N4.

Configuration Path Configuration → Gates → Gate Appointment Rules → select your gate
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biznovate
2.4 & 2.5 – Gate Printer & Gate Documents Setup

Setting up printing and document types for gate operations

2.4 Setting Up Gate Printer – Configuration → Gate → Printers

Navigate to: Configuration → Gate → Printers

Create a new printer for each gate stage that requires printing (e.g., outgate ticket printer)

Assign the correct IP address for the network printer

Enter a descriptive Description so operators can identify the printer

Associate the printer with the appropriate gate stage in the Gate Configuration

2.5 Gate Documents – Configuration → Gate → Documents

Navigate to: Configuration → Gate → Documents

Define document types that can be used for gate documents or any other type of documents (e.g., invoices)

Uses an associated style sheet to define the layout of data on the document

Although under Gate menu, gate documents are NOT restricted to gate documents only

A document type can be used in code extensions for ANY entity – not just gate entities

You can add new documents, and edit or delete existing documents from this view
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biznovate
2.5 – Gate Documents Screenshot

From the Training Manual

Gate Documents view showing document configuration options including document type definition and style sheet assignment
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Section 3.3

N4 Licensing

How It Works, View, Download & Upload

biznovate DAY 3



biznovate
3.3 – How N4 Licensing Works

The licence file controls system access and enabled modules

Licence File Format .lic file provided by Navis/Kaleris Support

Licence Contents Enabled modules, user session limits, facility count, expiry date, feature flags

Storage Location Uploaded via N4 Administration interface; stored on the N4 Application Server

Expiry Warning N4 warns when licence is within 30 days of expiry. System STOPS after expiry date.

Multiple Licences A single N4 installation may have multiple licence components (Base N4, Mobile, Billing, etc.)

Licence Check N4 validates the licence on EVERY startup. Always verify after uploading a new licence file.

View Licence Administration → N4 Licensing (shows expiry date, enabled modules, user session limits, facility count)

Upload Licence Administration → Security → Licenses → Licenses view → Upload Licence button

No Restart Needed No system restart required for most licence updates – verify by checking module availability

Set a calendar reminder 60 days before licence expiry to request renewal from Navis/Kaleris Support.
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biznovate
3.3 – N4 Licensing Screen

Administration → N4 Licensing from the Training Manual

N4 Licensing screen showing current licence details: expiry date, enabled modules list, user session limits, facility count and Download buttonAlways verify the expiry date AND enabled modules after uploading a new licence file.
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biznovate
3.3 – Viewing, Downloading & Uploading Licences

Step-by-step procedures for licence management

How to View / Download the Current Licence

Step 1: Navigate to Administration → N4 Licensing

Step 2: Review the licence details: expiry date, enabled modules, user session limits, facility count

Step 3: Confirm all expected modules are active (N4 Base, Mobile, Billing, XPS connection, etc.)

Step 4: Click Download to save a copy of the current licence file to your local machine as a backup

Step 5: Record the expiry date and set a calendar reminder 60 days before expiry

How to Upload / Activate a New Licence

Step 1: Obtain the new .lic file from Navis/Kaleris Support or your Navis account manager

Step 2: Navigate to Administration → Security → Licenses → Licenses view

Step 3: Click 'Upload Licence' and select the new .lic file from your local machine

Step 4: N4 will validate the licence file – a success confirmation message appears when accepted

Step 5: Review the licence details to confirm the new expiry date and all expected modules are present

Step 6: No system restart required for most licence updates – verify by checking module availability

Contact Navis/Kaleris support IMMEDIATELY if modules are missing or the expiry date is incorrect after upload. Keep a backup copy of EVERY licence file.
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XPS Administration Basics

User Admin, Roles, Equipment, Settings File, Ship Files
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biznovate
3.4 – What is XPS and How Does It Relate to N4?

XPS is the real-time graphical planning and dispatch module

Full Name eXpert Planning System (XPS)

Function Real-time equipment dispatch, yard crane planning, work instruction management

N4 Relationship XPS reads from N4 Operational Data Cache. N4 is the MASTER – XPS is view/dispatch only.

NOT a Separate DB Unlike old SPARCS/Express – XPS is NOT a separate database. Everything defined in N4 flows to XPS.

Access Method XPS client application via the XPS shortcut in the TOS Folder on your desktop

Config Files XPS operational parameters managed via the XPS settings file (XML/txt-based)

Primary Users Yard Planners, Vessel/Rail Planners, Execution Managers

Everything is defined in N4 and flows to XPS automatically. You should NEVER need to enter the same data twice.
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biznovate
3.4 – XPS User Administration Screenshot

XPS > File > Users from the Training Manual

XPS > File > Users showing user list and Add User form with role assignment, credentials and login detailsAll XPS users are created and managed in N4 Administration → Security → Users. They log in to XPS using their N4 credentials.
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biznovate
3.4 – XPS User Administration & Role Management

Creating and managing XPS users and roles

XPS User Administration

All XPS users are created and managed in N4 Administration → Security → Users

Navigate to: Administration → Security → Users. Click Add User.

Enter: Username, Full Name, Email Address, Default Role.

Assign the user to one or more Roles that include XPS-related privileges

Set a temporary password and enforce change on first login

Click Save. The user can now log in to XPS using their N4 credentials.

Role/Privilege Management for XPS

Yard Planner Role: view and plan container positions, manage yard allocations, create yard move filters

Vessel Planner Role: access vessel schedule, set work patterns, plan discharge/load, manage crane splits

Execution Manager Role: full access to all XPS dispatch and planning functions, complete moves, manage queues

View Only Role: read-only access to XPS yard views, vessel views and work queues – no planning functions

Creating a New XPS Role

Navigate to: XPS File → Group. Click New to create a new role.

Enter Role ID and Description. Click Save.

Select the role and click Add Privilege. Toggle privileges On/Off (XPS privileges are prefixed with 'XPS').

Navigate to File → User → Select the user → Assign the role.

XPS privileges are controlled through N4 Roles. Always add XPS-related privileges to the role before assigning to users.
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biznovate
3.4 – XPS Equipment Types Reference

All crane and equipment types available in XPS

RTG Rubber Tyred Gantry – mobile stacking crane for container yard operations

STS Ship-to-Shore crane – fixed quay crane for vessel loading and discharge

RS Reach Stacker – for stacking and transport in smaller terminals

EH Empty Handler – specialised crane for stacking empty containers

YT Yard Tractor – horizontal transport vehicles between quay and yard

Create Equipment XPS File → Maintain Cranes and RDTs OR Configuration → Equipment → Equipment

Equipment Steps Click Add (+) → Select Equipment Type → Enter Equipment ID, Name, Max Lift Capacity → Assign Facility → Save

Available in XPS Equipment is now available in XPS for dispatch and assignment to work queues
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biznovate
3.4 – Equipment Creation Form Screenshot

N4 Equipment creation form from the Training Manual

N4 Equipment creation form showing Equipment Type selector, Equipment ID, Name, Maximum Lift Capacity and Facility assignment fields highlighted

NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited DAY 3



biznovate
3.4 – Creating Pools & Points of Work (POW)

Group equipment and define work locations for dispatch

Creating Equipment Pools

In N4 (or XPS Equipment Control), navigate to: Equipment Control → Pools

Click Add (+). Enter Pool ID (e.g., 'RTG-ZONE-A') and Pool Type (must match equipment type)

Add equipment to the pool from the list of registered equipment

Save. The pool is now available for job assignment in XPS dispatch queues

Creating Points of Work (POW)

Navigate to: Equipment Control → Points of Work

Click Add (+). Enter POW ID (e.g., 'BLOCK-A01') and Description

Select the Equipment Pool that services this Point of Work

Define the yard block or zone this POW covers

Save. The POW is now available in XPS for job sequencing and dispatch
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biznovate
3.4 – Updating the XPS Sparcs Settings File

C:\ProgramData\Navis\xps\data Sparcs Settings.txt

What the Settings File Controls

Location: C:\ProgramData\Navis\xps\data Sparcs Settings.txt

Controls: job timeout values, priority weights, zone boundaries, display configurations

Format: XML/text-based configuration file (open with Notepad++, VS Code or similar)

NEVER open with Microsoft Word – it corrupts the file format

Key Settings That May Need Modification

Job timeout values: how long before a dispatched job is considered failed

Priority weights: container categories (Import vs Export vs Transship)

Zone boundary definitions: which yard blocks belong to which planning zone

Flex Field display settings: which unit flex fields are visible in XPS graphical views

Modification Procedure

Step 1: Obtain a copy of the current XPS settings file from the XPS server

Step 2: ALWAYS copy the file to a safe location BEFORE making any changes (keep a backup)

Step 3: Open the file using a plain text editor (Notepad++, VS Code – NOT Microsoft Word)

Step 4: After modifying, save the file and upload/replace on the XPS server

Step 5: Restart the XPS service to apply the changes (coordinate with Operations first)

ALWAYS take a backup BEFORE making any changes. Incorrect settings can cause dispatch failures. Test all changes in the test environment first.
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biznovate
3.4 – Updating XPS Licences & Ship Files

Separate from N4 licence – own file and procedure

Updating XPS Licences

XPS has its OWN licence file separate from the N4 licence

The XPS licence controls: number of connected equipment, cranes and concurrent planner sessions

Step 1: Obtain the new XPS license.xml file from Navis/Kaleris Support

Step 2: STOP the XPS service before uploading the new licence (coordinate with Operations Manager)

Step 3: Replace the existing XPS licence file in the XPS installation licence directory

Step 4: Restart the XPS service

Step 5: Log in to XPS and verify: Help → About or XPS Administration → Licensing

Step 6: Confirm the new expiry date and that all expected equipment counts and planner seats are correct

Accessing the Ship File in XPS (.NSD files)

Ship File Format: .NSD file (NAVIS Ship Definition) – XML-based vessel structural definition

Location: XPS ship file directory on XPS server (C:\ProgramData\Navis\xps\data\Ship Files)

Naming Convention: <LineOperator>.<VesselClass>.<VesselName>.nsd – MUST match N4 records exactly

Access in XPS: Vessel → Vessel Schedule → select vessel visit → Actions → Open bay plan

Import New Ship File: Copy .NSD file to the XPS ship file directory. No restart required.

Troubleshooting empty bay plan: verify NSD file name matches N4 Vessel Class ID exactly

The .NSD file name MUST match the N4 Vessel Class ID exactly – case sensitive. If they don't match, the bay plan will be empty in XPS.
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biznovate
3.4 – XPS Licence Screen Screenshot

XPS licence verification after upload

XPS Licence screen – showing licence verification after upload with equipment counts and planner seats correctly licensed
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biznovateHANDS-ON EXERCISE DAY 3

1.  Log in to N4 Mobile using your assigned credentials. Select Operator: LFT, Complex: LFT, Facility: LFT.

2.  Navigate to Yard Inspection. Find any container in the Yard. Update Seal Number 1 using (S). Verify in N4 Unit Inspector.

3.  Record a Damage (D) on the same container – enter damage type and component as directed by trainer.

4.  Record Placard for Export (P) for the container.

5.  Navigate to the Reefer Monitor. Find your assigned reefer container (e.g., REEF0703111 for User01).

6.  Update the reefer temperature reading. Toggle On Power / Take Off Power. Verify changes in N4.

7.  Open N4 Gates and create a new gate (ID, Name, Direction, Type as directed by trainer).

8.  Navigate to Gate Stages → Ingate → DI → Include Storage Paid Through Date → set Grace hour to 12hrs.

9.  Open the printer form → Create a new printer for outgate. Assign the IP address provided by trainer.

10.  Identify 4 business tasks in any gate form and explain their uses when Included or Excluded.

11.  Navigate to Administration → N4 Licensing. Record the current licence expiry date and list all enabled modules.

12.  Click Download and save the current licence file to your training desktop folder as a backup.

13.  Upload the test licence file provided by your trainer. Confirm the success message appears.

14.  After uploading, verify the new expiry date and confirm all modules remain enabled.

15.  In XPS: File → Users – create a new user and assign them the 'Yard Planner' role. Confirm user can log in to XPS.

16.  In N4 Configuration: create RTG equipment 'RTG-TrainXY'. Create Pool 'POOL-TrainXY'. Create POW 'POW-TrainXY'.

17.  Locate XPS settings file at C:\ProgramData\Navis\xps\data Sparcs Settings.txt. Open and identify 3 parameters.

18.  In XPS: navigate to the Vessel Schedule. Open the test vessel visit. Confirm bay plan is loaded from the ship file.

19.  Navigate to C:\ProgramData\Navis\xps\data\Ship Files. Find the .NSD file for the test vessel. Confirm name matches Vessel Class ID in N4.

Biznovate Technologies Limited  |  NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal



DAY

4
Advanced TOS Administration

Application Management | TOS Full/Partial Restart | EDI 
(Inbound/Outbound/Mapping) | Reporting

biznovate

T O D A Y ' S  A G E N D A

1.  TOS Architecture – Component Reference

2.  Full TOS STOP Sequence (11 Steps – in order)

3.  Full TOS START Sequence (11 Steps – in order)

4.  Partial TOS Restart

5.  Basic TOS Troubleshooting Framework (6 Steps)

6.  EDI Overview & Terminology

7.  Supported EDI Message Types

8.  Reading a BAPLIE File – Segment by Segment

9.  BAPLIE Segment Reference Table

10.  N4 EDI Setup Sequence (10 Steps)

11.  Inbound EDI Processing – 5 Stages

12.  Outbound EDI Processing – 5 Stages

13.  Key EDI Terminology Reference

14.  Common EDI Errors & Resolutions

15.  Reporting in N4 – Report Definitions

16.  Jasper Report Integration

17.  Scheduling Report Jobs

18.  Day 4 Lab Exercises



Section 4.1

TOS Application Management

Stop/Start Sequences, Partial Restart, Troubleshooting
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biznovate
4.1 – TOS Architecture Components Reference

All TOS components and their roles

N4 Application Server Java-based application server hosting the N4 application nodes

N4 Database Server Oracle or PostgreSQL – the MASTER record store for all N4 operational data

Cache Cluster Coherence Cache Cluster: PARTICIPANTS, OBJECTS, JOURNAL, MISC named caches

XPS Engine eXpert Planning System – separate service reading from Cache via the Bridge

EDI Engine Message broker handling inbound/outbound EDI file processing and scheduling

N4 Mobile Server Radio Server and N4 APM layer handling handheld RDT device sessions

N4 Share High-availability shared file system – CRITICAL for multi-node N4 deployments

ECN4 Crane Network 4 – interface for CTUI (Crane Team UI) crane workstation integration

ECN4 Daemon Background service maintaining ECN4 connections and crane session persistence
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biznovate
4.1 – Full TOS STOP & START Sequences

Execute EACH step in order – confirm service state before proceeding to next

STOP SEQUENCE (in this exact order)

1. Stop N4 billing service

2. Close XPS Client application (Users, XPS Decker, Dispatcher, Crane 
Scheduler, etc.)

3. Stop ECN4

4. Stop ECN4 daemon

5. Stop XPS

6. Stop XPS daemon (Bridged Service)

7. Stop Stand-by Center Node

8. Stop Center node

9. Stop all Cluster nodes one by one EXCEPT Node 1

10. Stop Node 1

11. Stop Apache Node Balancer Service (optional)

START SEQUENCE (in this exact order)

1. Start Node 1

2. Start Center Node

3. Start XPS daemon (Bridged Service)

4. Start XPS

5. Start all other nodes one by One

6. Start ECN4 daemon Service

7. Start ECN4 Webservice

8. Start Standby Center Node

9. Start Apache Node Balancer Services

10. Launch XPS Client Services (Decker, Dispatcher, CraneScheduler, etc.)

11. Start billing services

NEVER perform a full TOS stop during active vessel operations without explicit written sign-off from the Operations Manager. 15 minutes advance warning minimum – 30 
minutes is best practice.
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biznovate
4.1 – Partial TOS Restart Reference

Restart specific services without affecting others – always try this FIRST

Identify failing service Check logs and user reports to determine which specific module is unresponsive

Restart EDI Engine (Linux) systemctl restart navis-edi

Restart EDI Engine (Windows) net stop NavisEDI  |  net start NavisEDI

Restart XPS (Linux) systemctl restart navis-xps

Restart XPS (Windows) net stop NavisXPS  |  net start NavisXPS

Restart N4 Mobile (Linux) systemctl restart navis-mobile

Monitor logs (Linux) tail -f /opt/navis/n4/log/server.log

Monitor logs (Windows) Monitor via log viewer in Windows event viewer or application log directory

Always keep an N4 log tail running (tail -f server.log) during a restart so you can see startup progress in real time and catch any errors immediately.
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biznovate
4.1 – Basic TOS Troubleshooting Framework

6-step systematic approach to resolving TOS issues

6-Step TOS Troubleshooting Framework

Step 1 – Identify Scope: Is the issue affecting ALL users (server-side problem) or ONE user/workstation (client-side problem)?

Step 2 – Check N4 Logs: Review n4.log / server.log on the application server for ERROR or WARN entries and stack traces

Step 3 – Check EDI Logs: If the issue involves message processing failures, check the EDI engine log files

Step 4 – Check Connectivity: Verify network: client → app server → database. Check firewall rules if applicable.

Step 5 – Restart Service: If logs show a hanging thread, memory issue or unresponsive module – perform targeted partial service restart

Step 6 – Escalate: If unresolvable, raise a support ticket via the Navis Community Portal with FULL log files attached
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Section 4.2

Electronic Data Interchange (EDI)

Overview, BAPLIE, Setup Sequence, Inbound & Outbound Processing

biznovate DAY 4



biznovate
4.2 – EDI Overview & Terminology

From the Training Manual

EDI overview: Electronic Data Interchange definition, standards (UN/EDIFACT, ANSI X12), file 
format (ASCII text, delimiters), message types

EDI terminology: Message, Message Type, Segment, Field, Segment ID – how EDI messages 
are structured
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biznovate
4.2 – Supported EDI Message Types

Full reference from the Training Manual

EDI Message Types table: BAPLIE, COPRAR, COARRI, COPINO, COPARN, CODECO, CUSRES, 
APERAK, IFTMBC, TPFREP standard and purpose

EDI Message Types (continued): 417/418 Rail (X12), additional EDIFACT message details and 
purposes
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biznovate
4.2 – EDI Message Types Reference

All supported EDI message types and their purpose in N4

BAPLIE 1.5 & 2.0 Vessel Bay Plan / Stow Plan (Inbound from carrier, Outbound to carrier)

COPRAR Load or Discharge List (container lists for vessel operations)

COARRI Container Activity Report – confirms vessel loads and discharges to carriers

COPINO Appointment / Pre-Advise (truck gate pre-notification from carrier)

COPARN Export Booking (booking from carrier to terminal)

CODECO InGate/OutGate Activity (inbound/outbound, release confirmations)

CUSRES Customs Release (from customs authority to terminal)

APERAK Acknowledgement message

IFTMBC Booking Confirmation

TPFREP Terminal Performance Report

417/418 Rail Rail Waybill / Rail Consist (ANSI X12 standard, North America)
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biznovate
4.2 – Reading a BAPLIE File – Example

From the Training Manual

BAPLIE EDI file example showing the 3 sections: Header (UNB/UNH), Body (TDT/LOC/MEA/EQD segments) and Footer (UNT/UNZ) with field delimiter labels
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biznovate
4.2 – BAPLIE File – Segment by Segment

Understanding each segment and what it contains

UNB+UNOA:2+APL+FCP PLANNING+030626:1314+0'

← HEADER (Interchange): identifies sender, receiver, date/time

UNH+1+BAPLIE:D:95B:UN:SMDG20'

← Message Header: Type=BAPLIE, Release=95B

TDT+20+216R+++MSC:172:20+++H3LV:103::MSC SANDRA'

← VESSEL: voyage=216R, line=MSC (BIC=172), callsign=H3LV, name=MSC SANDRA

LOC+147+0010882::5'

← Bay Position: 001=Bay, 08=Row, 82=Tier (above deck)

MEA+WT++KGM:16600'

← Weight: 16,600 KG gross weight

LOC+9+AUSYD' LOC+11+NZLYT' LOC+83+BRRIG'

← POD=AUSYD, POD2=NZLYT, Destination=BRRIG

EQD+CN+ASCU2643846+2200++3+5'

← Container: ID=ASCU2643846, ISO=2200(20ft GP), Full=3, Transship=5

UNT+16179+1' UNZ+1+0'

← FOOTER: segment count=16179, interchange end

Delimiters: + = field separator | : = sub-field separator | ' = end of segment (apostrophe character)
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biznovate
4.2 – BAPLIE Segment Reference

Key segments and what each contains

EQD Segment Equipment Detail: container number, ISO type, Full/Empty status (3=Full, 5=Empty), Import/Transship status

TDT Segment Transport: voyage number, line operator SCAC/BIC, radio call sign, vessel name

LOC+5 Port of Loading (POL)

LOC+9 Port of Discharge (POD)

LOC+11 Second Discharge Port (POD2)

LOC+83 Destination

LOC+147 Bay Position on the vessel (BBBRRTT format)

MEA+WT Measurements – weight in KGM (kilograms)

Delimiter + Field separator within a segment

Delimiter : Sub-field separator within a field

End of Line ' Marks the end of each segment (apostrophe character)
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biznovate
4.2 – N4 EDI Setup Sequence Flowchart

From the Training Manual

N4 EDI Setup flowchart (Part 1): Start → Add Trading Partners → Set up EDI Message Types 
and Maps → Add Mailboxes → Add new EDI Message Type? → decision path

N4 EDI Setup flowchart (Part 2): Edit EDI Message Map? → Export schema files → Export 
Message Map → Edit Map → Import Map → Add EDI Session → End
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biznovate
4.2 – Additional EDI Setup Screenshots

More EDI configuration detail

EDI Setup (continued): full sequence flowchart showing all 10 configuration steps EDI configuration: Session, Filter, Mailbox and Job setup screens
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biznovate
4.2 – N4 EDI Configuration Sequence (10 Steps)

Administration → EDI → EDI Configuration – follow in this exact order

1

EDI Directory
Structure

Unique folder per direction, 
message type and trading partner

2

Define EDI
Message Types

Version/release. Assign mapping 
file (custom or Navis default).

3

Import Message
Maps (XENOS)

Import predefined Message Maps 
via XENOS GoXML tool

4

Link to
Message Classes

Link Message Types to Classes 
(stowplan, booking, activity, 

release)

5

Create Trading
Partners

Organisations exchanging EDI with 
the terminal

6

Create
Mailboxes

One per direction/message type 
combo per Trading Partner

7

Create EDI
Filters

Session Filters: translate partner 
codes to terminal codes

8

Create EDI
Sessions

Session = Filter + Mailbox + 
Message Type + Direction

9

Create EDI
Jobs

Schedule polling/extract frequency. 
Inbound and outbound.

10

Validate &
Execute

Post inbound / Extract outbound. 
Verify in Batch Inspector.
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biznovate
4.2 – Inbound EDI Processing – 5 Stages

From the Training Manual

Inbound EDI Stage 1 (RECEIVE) and Stage 2 (LOAD): raw EDI file placed in directory, then 
moved to N4 Staging Tables. No operational data created yet.

Inbound EDI Stage 3 (CLASSIFY) and Stage 4 (MAP): N4 determines Message Type and EDI 
Partner, creates batches, then applies XENOS GoXML mapping to create transactions.
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biznovate
4.2 – Inbound EDI Stage 5: POST

Committing transactions to the N4 database

Inbound EDI Stage 5 (POST): N4 finds key entities, commits transactions to N4 database. Can be automatic (session setting) or manual. Creates operational data.
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biznovate
4.2 – Inbound EDI – 5 Stages Reference

What happens at each stage of inbound processing

1. RECEIVE Raw EDI file placed in the designated inbound directory by VAN (Value Added Network) via FTP or SMTP

2. LOAD
N4 moves file to Staging Tables. Creates Interchange and Segment records. Archives original. Does NOT 
create/modify operational data yet.

3. CLASSIFY
N4 inspects the interchange to determine Message Types and EDI Partner. Creates one EDI Batch per distinct 
Message Type.

4. MAP
N4 applies the correct EDI Map (XENOS GoXML engine). Reads EDI Segments, applies Filters, translates EDI to XML, 
creates committable EDI Transactions.

5. POST
N4 finds key entities (containers, vessel visits, bookings), commits transactions to N4 database. Can be automatic or 
manual.
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biznovate
4.2 – Outbound EDI Processing – 5 Stages

From the Training Manual

Outbound EDI Stage 1 (SELECT) and Stage 2 (EXTRACT): N4 finds events since last extract 
date, extracts transactions and applies Session Filters (translate terminal codes to partner codes)

Outbound EDI Stage 3 (MAP), Stage 4 (UNLOAD) and Stage 5 (SEND): XENOS maps to EDI 
format, places in outbound mailbox, sends to trading partner and archives
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biznovate
4.2 – Outbound EDI – 5 Stages Reference

What happens at each stage of outbound processing

1. SELECT N4 finds events since last extract date. Checks event type supported and defined in EDI Session.

2. EXTRACT N4 extracts transactions and applies Session Filters (translate terminal codes to partner codes).

3. MAP XENOS GoXML engine maps extracted transactions from N4 XML to the outbound EDI file format.

4. UNLOAD Maps EDI file into the designated outbound mailbox directory. Loads segments to EDI Segments table.

5. SEND Sweeps the outbound mailbox directory and sends file to trading partner. Archives sent file in subdirectory.
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biznovate
4.2 – Key EDI Terminology & Error Reference

From the Training Manual

Key EDI Terminology: Trading Partner, Mailbox, Session, Session Filter, Batch, Run, 
Transaction, Interchange, Staging Tables, Job, Posting Rules

Common EDI Errors & Resolutions table showing error messages, causes and resolution steps
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biznovate
4.2 – Common EDI Errors & Resolutions

When things go wrong – what the error means and how to fix it

ArrayIndexOutOfBoundsException / message=68 EDI file empty or wrong standard. → Verify correct file and EDIFACT vs X12 standard.

EDI Envelope or Header not found Missing header or wrong delimiter character. → Correct EDI file header/delimiter and reload.

EDI Trading Partner XXX not found
Partner ID in file doesn't match any Trading Partner in N4. → Match Trading Partner in N4 to sender ID in UNB 
segment.

EDI session for Partner XXX Message ABC does not exist
Session version/release doesn't match BAPLIE message codes. → Match Session message map version/release to 
UNH segment codes.

Unrecognized SCAC Line Id / Invalid BIC
SCAC or BIC code in EDI file not found in N4 Line Operators. → Add SCAC/BIC to the Line Operator in N4 
Configuration.

XXX is not in the itinerary for carrier visit ABC Port code in EDI not in vessel visit port rotation. → Edit the Port Rotation to add the missing routing point.

Invalid unitRouting.rtgPOD / Unknown location code
Location code in EDI not in N4 UN Location/Routing Point. → Add routing point to Administration → EDI → EDI to 
UN Location table.

Could not find Vessel Visit for convention XXX
Vessel convention in EDI doesn't match N4 Vessel Visit. → Ensure Vessel Visit Radio Call Sign matches EDI TDT 
segment.
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Section 4.3

Reporting in N4

Report Definitions, Jasper Integration & Report Scheduling
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biznovate
4.3 – Jasper Report Integration

JasperSoft Studio and N4 report deployment

Jasper report integration: .jrxml design file → compile to .jasper → deploy via Administration 
→ Reports → Jasper Reports → Upload. Shows VW_ data source views.

Modifying existing reports: Report Design → Export to .jrxml → Open with Jasper iReport 
Designer → edit → re-upload
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biznovate
4.3 – Reporting Reference

N4 built-in reports and Jasper integration

Reportable Entities
Unit Visits, Vessel Visits, Gate Transactions, Equipment, Yard Inventory, Bookings, BLs, Events, Holds/Permissions, 
Financial data

Output Formats PDF, CSV, Excel, HTML (as configured in the report definition)

Filter Criteria Same filter logic as N4 list views – apply criteria to limit the report scope

Column Selection Choose which attributes (fields) to include as columns in the report output

Report Scheduling Scheduled via Administration → Reports → Report Jobs. Automatic at defined intervals.

Jasper File Format .jrxml (design file) compiled to .jasper (execution file)

Design Tool JasperSoft Studio – Eclipse-based IDE (free from jaspersoft.com)

N4 Data Sources ALWAYS use VW_ views – officially supported and version-safe across N4 upgrades

Deployment Compile .jasper → upload via Administration → Reports → Jasper Reports → Upload

Report Jobs New Job → select report → set schedule → set output format → set delivery → Save
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biznovateHANDS-ON EXERCISE DAY 4

1.  RDP to the TOS test server. Perform a partial restart of the EDI Engine service. Monitor the log file during restart.

2.  Create a new Shipping Line (Line Operator) with ID UXY (XY = your user number). BIC must match the ID.

3.  Create a Vessel Service, Vessel and Vessel Visit for your new Line Operator. Advance the visit to ARRIVED.

4.  Navigate to Administration → EDI → EDI Configuration. Create a Trading Partner named UXY.

5.  Add an inbound Mailbox: Direction=Receive, Directory=C:\UXY\test, Communication Type=NONE. Name it BAPINUXY.

6.  Create EDI Session UXYBAPIN: Direction=Receive, Message Class=STOWPLAN, Message Map=BAPLIE_IN_20_MAEU, Mailbox=BAPINUXY.

7.  Modify the sample BAPLIE file (USERXY.baplie.edi.txt) – update Line ID, Voyage ID, Vessel Name and Call Sign to match your records.

8.  Load your modified BAPLIE via Administration → EDI → EDI Load (do NOT check Post Immediate). Review EDI Batch Inspector for load errors.

9.  Post the BAPLIE. Review and resolve any posting errors. Confirm containers appear in Operations → Vessel → Vessel Visit → Onboard.

10.  Create an outbound COARRI session. Discharge one container to create an event. Extract the COARRI and verify the output file.

11.  Create an outbound EDI Job with a 5-minute repeat interval. Schedule it and verify it executes successfully via Execution Logs.

12.  Create a Report Definition for Unit Visits: filter=IN YARD AND Category=IMPORT. Columns: Unit ID, ISO Type, Line Operator, Position, POD, 
Days In Yard.

13.  Run the report in CSV format. Verify the output contains unit data matching your filter.

14.  Schedule the report to run daily at 06:00 and deliver to your training email address.
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DAY

5
N4 Billing

Billing Overview | Configuration | Contracts | Invoicing | 
Payments | Sequencing

biznovate

T O D A Y ' S  A G E N D A

1.  Introduction & Overview of N4 Billing

2.  Billing Charge Types

3.  Modes of Operation in N4 Billing

4.  Operations Mode – Invoices, Payments, Credit Notes, Statements

5.  Configuration Mode – Tariffs, Contracts, Service Types, GL Codes

6.  Administration Mode – Sequencing, Settings, Billing Groups

7.  Billing Configuration Order (8 Steps)

8.  Service Type Configuration

9.  Tariff Configuration & Tier Steps

10.  GL Code Configuration

11.  Invoice Type Configuration

12.  Contract Setup & Tariff Rate Configuration

13.  Invoice Generation Process

14.  Reviewing & Approving an Invoice

15.  Recording Payments

16.  Issuing Credit Notes

17.  Invoice Number Sequencing

18.  Billing Configuration Summary Checklist

19.  Day 5 Lab Exercises



Section 5.1

N4 Billing Overview

What N4 Billing Does and How It Works
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biznovate
5.1 – N4 Billing Overview

Core function, data sources and output

Core Function Automated terminal charge calculation and invoice generation based on N4 operational events

Data Source Reads directly from N4: unit visit events, gate transactions, vessel visits, reefer monitoring, damage records

Charge Types
Storage/demurrage, reefer monitoring/power, crane moves, gate transactions, cleaning, damage repair, customs 
examination

Output Invoice documents (PDF/print), financial postings to GL, payment records, customer statements, credit notes

Access N4 → Billing mode selector (SEPARATE from Operations, Configuration and Administration)

Billing Events
N4 unit events flagged as Billable (in the Event Type definition) are extracted to the billing table for invoice 
generation

Module Licensing N4 Billing is a separately licensed module. Verify it appears in the N4 Licence screen.

N4 Billing eliminates manual invoicing by automatically applying configured tariffs to unit visits based on actual operational data captured by N4.
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biznovate
5.2 – Modes of Operation in N4 Billing

Three billing modes – Operations, Configuration and Administration

Operations Mode – Day-to-Day Billing

Invoices – View, generate, approve and dispatch invoices to customers

Payments/Receipts – Record and reconcile customer payments against 
outstanding invoices

Credit Notes – Issue credits to reverse or reduce previous invoices 
(corrections or disputes)

Customer Statements – Generate outstanding balance summaries per 
customer/line operator

Billing Events – View the event-based triggers that generated charges for 
specific units/visits

Configuration & Administration Modes

CONFIGURATION: Tariffs – Define charge rates and rules (base tariff 
schedule)

CONFIGURATION: Contracts – Customer-specific pricing overrides to the 
standard tariff

CONFIGURATION: Invoice Types – Standard, Proforma, Credit Note 
document templates

CONFIGURATION: Service Types – Storage, Reefer, Gate Move, Crane Move, 
etc.

CONFIGURATION: GL Codes – Map billing charges to financial general ledger 
codes

CONFIGURATION: Tax Codes – Configure taxes per service type or customer

ADMINISTRATION: Billing Settings – Currency, rounding, free time defaults

ADMINISTRATION: Sequencing – Invoice/credit note/receipt number 
formats

ADMINISTRATION: Billing Groups – Restrict which customers a user can see

ADMINISTRATION: Archive – Archive historical invoices and billing records
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Section 5.3

Billing Configuration

Service Types, Tariffs, GL Codes, Invoice Types

biznovate DAY 5



biznovate
5.3 – Billing Configuration Order – 8 Steps

Follow this EXACT sequence to avoid dependency errors

1

Configure
GL Codes

Map to your terminal's chart of 
accounts

2

Configure
Service Types

Define chargeable services and link 
to GL codes

3

Configure
Invoice Types

Standard, Proforma, Credit Note 
document templates

4

Configure
Sequencing

Number formats – do this BEFORE 
first invoice!

5

Configure
Tariffs

Base charge rates for all service 
types with tier steps

6

Configure
Contracts

Customer-specific overrides to 
base tariffs

7

Configure
Billing Settings

Global parameters: currency, free 
time defaults, rounding

8

Test Invoice
Generation

Test in test environment before 
going live
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5.3 – Service Type Configuration

Billing → Configuration → Service Types

Service Type ID Unique identifier for the chargeable service (e.g., STORAGE-20FT, REEFER-MON)

Description Human-readable description of the service

Chargeable Entity What entity the charge applies to: Unit, Vessel Visit, or Gate Transaction

Charge Basis How the charge is calculated: Per Day | Per Move | Per Unit | Per Container | Per Hour

GL Code Link to the General Ledger code for financial accounting

Storage Daily storage charge on units IN YARD beyond the free time period

Reefer Monitoring Per-day or per-plug-event charge for reefer container power monitoring

Gate Transaction Charge per truck gate transaction (inbound or outbound)

Crane Move Charge per crane lift (discharge or load move)
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5.3 – Tariff Configuration Screenshot

Billing → Configuration → Tariffs from the Training Manual

N4 Tariff configuration screen showing tariff lines with Service Type, Rate, Currency and Conditions columns. Tier step configuration visible.
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5.3 – Tariff Configuration Reference

Billing → Configuration → Tariffs

Tariff ID Unique identifier for the tariff schedule

Effective Date Date from which this tariff applies (required field)

Expiry Date Date after which this tariff is no longer valid (leave blank for open-ended)

Tariff Lines One line per Service Type: Rate, Currency, Unit of Measure, Conditions

Conditions Filters that determine when the rate applies (size, category, carrier, container type)

Tier Steps Progressive rate increases based on dwell time. Example: USD 10/day days 1-7, USD 25/day from day 8+

GL Code Configuration Billing → Configuration → GL Codes. Maps billing charges to terminal's financial accounting system.

Invoice Types Standard Invoice | Proforma Invoice | Credit Note | Statement (summary of outstanding invoices)

Create GL codes matching your terminal's chart of accounts. Link each GL code to one or more Service Types.
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Contract Setup & Invoicing

Contracts, Invoice Generation, Payments, Credit Notes
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biznovate
5.4 – Contract Setup

Billing → Configuration → Contracts

Creating a Contract

Navigate to: Billing → Configuration → Contracts

Click New Contract. Enter: Contract ID, Customer (Line Operator or Organisation), Effective Date, Expiry Date

Add Contract Lines for each service type: specify the contracted rate, currency and conditions

A contract can: override the base tariff rate, provide extended free time, or apply percentage discounts

Click Save and then Activate the contract

Contract Precedence Rule

Contract rates ALWAYS take precedence over the standard published tariff when BOTH are active

This applies when both the contract AND the tariff are active for the same service type and customer

ALWAYS verify contract status (Active/Expired) when investigating unexpected or disputed charges

An expired contract will automatically revert to the standard published tariff

Tip: Always check contract status (Active/Expired) first when a customer disputes a charge. The contract may have expired without renewal.
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5.5 – Invoice Generation Process

Billing → Operations → Invoices

N4 Invoice generation preview showing customer name, billing period, line items (service type, quantity, rate, amount), free time applied and total amount dueOnce an invoice is Approved and Dispatched it CANNOT be edited. To correct: (1) Issue Credit Note to reverse, (2) Re-invoice with correct charges.
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5.5 – Invoice Generation Step by Step

Billing → Operations → Invoices

Invoice Generation Process

Step 1: Click Generate Invoice (or use batch invoice generation for multiple customers)

Step 2: Select the Customer (Line Operator / Organisation) and billing period (or specific unit/vessel visit)

Step 3: N4 calculates all applicable charges based on: tariffs, active contracts, operational events and free time rules

Step 4: REVIEW the invoice preview carefully – verify all line items, rates, free time applied and totals

Step 5: Click Approve to finalise the invoice. This commits it PERMANENTLY.

Step 6: Click Dispatch to send to the customer (email, print or portal)

Recording a Payment

Navigate to: Billing → Operations → Payments

Click New Payment. Select the Customer (N4 displays all outstanding invoices for that customer).

Enter: Payment Amount, Payment Date, Payment Method (Bank Transfer, Cash, Cheque, Online)

Allocate the payment against specific invoices (full or partial allocation). Enter bank reference number.

Click Save. Invoice status updates to Partially Paid or Fully Paid.

Issuing a Credit Note

Navigate to: Billing → Operations → Credit Notes

Click New Credit Note. Link it to the original invoice number.

Select the line items to credit (full reversal or partial credit on specific lines)

Enter the reason for the credit note (REQUIRED for audit trail)

Approve and Dispatch the credit note

Once Approved and Dispatched, an invoice CANNOT be edited. Always review the invoice preview BEFORE clicking Approve.
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5.6 – Payment Recording Screenshot

Billing → Operations → Payments from the Training Manual

N4 Payment recording screen showing customer name, list of outstanding invoices, payment amount field, payment method selector and allocation grid
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Invoice Number Sequencing

Configure BEFORE Generating the First Invoice
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5.7 – Invoice Sequencing Screenshot

Billing → Administration → Sequencing from the Training Manual

N4 Sequencing configuration screen showing Document Types, Prefix, Start Number, Number Length, Suffix, Reset Annually fields and example format
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5.7 – Invoice Number Sequencing Reference

Configure BEFORE generating the first invoice – critical setup step

Document Types Invoice, Credit Note, Receipt, Statement – each has its OWN sequence definition

Prefix Text added BEFORE the sequence number (e.g., 'INV-2024-')

Start Number The first number in the sequence (typically 00001)

Number Length Total digits in the numeric part, zero-padded (e.g., 5 digits gives 00001–99999)

Suffix Optional text appended AFTER the number

Reset Annually Whether the sequence resets to Start Number at beginning of each year

Example Format INV-2024-00001 → Prefix='INV-2024-' + Start=00001 + No Suffix

Configure sequencing BEFORE generating the first invoice. Once invoices have been generated, changing the numbering format creates GAPS in the invoice number 
series. Any gaps must be documented for audit purposes.
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Billing Configuration Checklist

Complete All Steps Before Go-Live
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5.8 – Billing Configuration Summary Checklist

Complete all steps BEFORE generating live invoices

Step 1 Configure GL Codes to match your terminal's chart of accounts

Step 2 Configure Service Types (chargeable services) and link to GL codes

Step 3 Configure Invoice Types (Standard, Proforma, Credit Note) and document templates

Step 4 Configure Invoice/Credit Note/Receipt Sequencing (number format) – BEFORE first invoice

Step 5 Configure Base Tariffs with rates for all applicable service types (with tier steps)

Step 6 Configure Contracts for key customers with agreed pricing overrides

Step 7 Configure Billing Settings (currency, global free time defaults, rounding rules)

Step 8 Test invoice generation in test environment – verify calculation, free time and tariff application

Step 9 Train finance staff on invoice approval workflow and payment recording before go-live

All 9 steps must be completed and verified before generating live invoices at Lekki Freeport Terminal.

NAVIS SPARCS N4 & XPS TOS Training  |  Lekki Freeport Terminal  |  Biznovate Technologies Limited DAY 5



biznovateHANDS-ON EXERCISE DAY 5

1.  Create a GL Code for 'Storage Revenue' linked to your terminal's chart of accounts code.

2.  Create a Service Type for '20ft Storage' with a Per Day charge basis, linked to the GL code above.

3.  Create a Tariff with two tier steps: USD 10/day for days 1-7 and USD 25/day from day 8 onwards.

4.  Create a Contract for the test carrier (MAEU) with a 10-day free time period for storage.

5.  Generate a test invoice for a unit that has been IN YARD for 12 days. Verify: days 1-10 free (contract), days 11-12 at USD 25/day = USD 50 
total.

6.  Review the invoice preview carefully. Verify all line items, rates, free time applied and totals are correct.

7.  Click Approve to finalise the invoice. Confirm it is now LOCKED and cannot be edited.

8.  Record a full payment against the test invoice. Confirm the invoice status changes to Fully Paid.

9.  Issue a Credit Note for 2 days of storage charges. Enter the reason. Confirm the credit note is linked to the original invoice.

10.  Configure Invoice Sequencing to use the format: INV-2024-XXXXX (5 digits). Confirm the next invoice uses this format.

11.  Schedule an automated billing run for storage charges to execute nightly at 23:00.

12.  Review the 5.8 Billing Configuration Summary Checklist. Confirm all 9 steps are completed for the test environment.
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Programme Complete
NAVIS SPARCS N4 & XPS – 5-Day IT Administrator Training Programme | Lekki Freeport Terminal

Day 1 N4 Basics – Architecture, Topology, Data Model, Navigation, Vessel Operations

Day 2 Basic Administration – Reference Data, Business Rules, Security, Settings & Flex Fields

Day 3 N4 Mobile, Gate Configuration, N4 Licensing, XPS Administration Basics

Day 4 Advanced Admin – TOS Restart, EDI (Inbound/Outbound), BAPLIE, Reporting

Day 5 N4 Billing – Tariffs, Contracts, Invoice Generation, Payments, Sequencing

biznovate Phone: 07059667999 (Call + WhatsApp)  |  Email: hello@biznovatetech.com  |  Web: www.biznovatetech.com
(c) 2026. Biznovate Technologies Limited.
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